New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed to build lxml during install on Ubuntu 16.04.1 LTS #36

Closed
NathanDotTo opened this Issue Sep 1, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@NathanDotTo
Copy link
Contributor

NathanDotTo commented Sep 1, 2016

Failed to build lxml
Installing collected packages: Django, ecdsa, pycrypto, paramiko, requests, markupsafe, Jinja2, Unidecode, python-slugify, sqlparse, django-debug-toolbar, lxml, graphviz, ncclient, pyang
Running setup.py install for lxml ... error
Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;file='/tmp/pip-build-3n0oBg/lxml/setup.py';exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))" install --record /tmp/pip-q4GDKX-record/install-record.txt --single-version-externally-managed --compile:
Building lxml version 3.4.4.
Building without Cython.
ERROR: /bin/sh: 1: xslt-config: not found

** make sure the development packages of libxml2 and libxslt are installed **

Solved with:

sudo apt-get -y install libxml2-dev libxslt-dev

@NathanDotTo NathanDotTo changed the title Failed to build lxml duering install on Ubuntu 16.04.1 LTS Failed to build lxml during install on Ubuntu 16.04.1 LTS Sep 1, 2016

@pgohite

This comment has been minimized.

Copy link
Contributor

pgohite commented Sep 1, 2016

Thanks. Instructions to install these libraries are provided in README, installation section.

@pgohite pgohite closed this Sep 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment