New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NPCs don't look up or down #1344

Closed
Drydon opened this Issue Nov 13, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@Drydon

Drydon commented Nov 13, 2017

This is a bug, I'm sure. Now, I'm not sure if this is a problem with the plugin, or a problem with the server, but when trying to use the /npc look command, the NPCs don't look up or. They just look straight. Even when I position it up. It doesn't work. Please help?

@Midnight9746

This comment has been minimized.

Show comment
Hide comment
@Midnight9746

Midnight9746 Jan 23, 2018

It might be a visual thing with the npc, you could try setting an anchor while up in the air (/npc anchor) and then /citizens save and reload to see if they take after the head angle you saved.

That or you might be missing a plugin that makes you see them do that. (Since they're not really a mob or player, your server might not be sending the right packets to your cliten to show them move.

What I mean is, your game window tells the server things and the server talks back such as your game says "hey I'm right here at x y z" an the server allows you to see the blocks there and can also tell someone else, "there's a player right infront of you!"

Your game / cliten might not be sending or receiving anything that lets it know that the mob on the server is moving.

Just a thought

Midnight9746 commented Jan 23, 2018

It might be a visual thing with the npc, you could try setting an anchor while up in the air (/npc anchor) and then /citizens save and reload to see if they take after the head angle you saved.

That or you might be missing a plugin that makes you see them do that. (Since they're not really a mob or player, your server might not be sending the right packets to your cliten to show them move.

What I mean is, your game window tells the server things and the server talks back such as your game says "hey I'm right here at x y z" an the server allows you to see the blocks there and can also tell someone else, "there's a player right infront of you!"

Your game / cliten might not be sending or receiving anything that lets it know that the mob on the server is moving.

Just a thought

@fullwall

This comment has been minimized.

Show comment
Hide comment
@fullwall

fullwall Mar 15, 2018

Member

What entity type? I can't reproduce this in 1.12 on latest Citizens. Please reopen if this is still an issue.

Member

fullwall commented Mar 15, 2018

What entity type? I can't reproduce this in 1.12 on latest Citizens. Please reopen if this is still an issue.

@fullwall fullwall closed this Mar 15, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment