New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compatible with Via Version #1565

Open
alexlazarev98 opened this Issue Sep 10, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@alexlazarev98

alexlazarev98 commented Sep 10, 2018

Hello.
When I run Citizens + ViaVersion players can't join the server.
In attempt of the player to come into the console writes:
(Player) lost connection: Internal Exception: io.netty.handler.codec.EncoderException: java.lang.IllegalArgumentException: Unknown mob network type id -1

The output of command /version on my server is: 294(Spigot 1.12.2
The output of command /version citizens on my server is: 1568(2.0.24)

@mcmonkey4eva

This comment has been minimized.

Show comment
Hide comment
@mcmonkey4eva

mcmonkey4eva Sep 10, 2018

Member

Post actual version output. Any alterations made to the output irrelevantizes and falsifies it.

Please also post the version of ViaVersion you have in use.

I will reopen this issue when that information is provided.

Member

mcmonkey4eva commented Sep 10, 2018

Post actual version output. Any alterations made to the output irrelevantizes and falsifies it.

Please also post the version of ViaVersion you have in use.

I will reopen this issue when that information is provided.

@alexlazarev98

This comment has been minimized.

Show comment
Hide comment
@alexlazarev98

alexlazarev98 commented Sep 11, 2018

Look
screenshot_20180911201533

@mcmonkey4eva mcmonkey4eva reopened this Sep 11, 2018

@mcmonkey4eva

This comment has been minimized.

Show comment
Hide comment
@mcmonkey4eva

mcmonkey4eva Sep 11, 2018

Member

Thank you!

That Spigot build looks a bit old (237 versions behind)! Might be relevant to update that: https://www.spigotmc.org/wiki/buildtools/

What client version are players attempting to connect from?

I'm not sure why you're running ViaVersion... you're running a 1.12.2 server, and ViaVersion doesn't yet support 1.13...

Are you perhaps also running ViaBackwards or ViaRewind, to allow in older clients?

Member

mcmonkey4eva commented Sep 11, 2018

Thank you!

That Spigot build looks a bit old (237 versions behind)! Might be relevant to update that: https://www.spigotmc.org/wiki/buildtools/

What client version are players attempting to connect from?

I'm not sure why you're running ViaVersion... you're running a 1.12.2 server, and ViaVersion doesn't yet support 1.13...

Are you perhaps also running ViaBackwards or ViaRewind, to allow in older clients?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment