Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

I'm getting and error with yaw #1929

Closed
TheModz01 opened this issue Aug 24, 2019 · 2 comments

Comments

@TheModz01
Copy link

commented Aug 24, 2019

I'm getting this error: https://pastebin.com/c3fFcGyf

The output of command /version on my server is: PaperSpigot 1.12.2-R0.1-SNAPSHOT
The output of command /version citizens on my server is: (2.0.25-SNAPSHOT (build 1744)

@mcmonkey4eva

This comment has been minimized.

Copy link
Member

commented Aug 24, 2019

This error was moved from Discord, so I'll include a copy of my response on Discord as well:
that's been known to happen in certain situations - yaw or other Location data ends up set to infinity and that error results from that
the most immediate fix is to find the infinite value in your saves.yml and set it to 0
iirc it should be displayed as Infinite
or similar to that
that might be one worth posting an issue for, so that it can be patched internally to protect against infinite values

It'd be very good for Citizens to validate and autocorrect Location values anywhere they're read (and of course ideally the invalid locations prevented from ever be set but that's more complicated)

@mcmonkey4eva

This comment has been minimized.

Copy link
Member

commented Sep 17, 2019

Probably fixed in latest builds via CitizensDev/CitizensAPI@b174e10

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.