Skip to content
Information repository for Waterloo Region races in 2019 federal election
Python Ruby Shell
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
docs
marketing
scripts
.gitignore
.travis.yml
CNAME
Gemfile
Gemfile.lock
LICENSE
README-classificatons.md
README-updating.md
README.md

README.md

Waterloo Region Votes Federally

This is a hostile fork of https://github.com/wrvotes . Its intention is to adapt the previous codebase for use with the 2019 federal election.

This repository is published to https://civictechwr.github.io/WRVotesFed

Contributing

Dependencies:

  • Ruby
  • Bundler
  • Jekyll

To get started locally:

  • Clone the repo: git clone https://github.com/CivicTechWR/WRvotesFed.git
  • Install gems: bundle
  • Move into the website directory: cd docs
  • Start the local server: jekyll serve

Getting started on OSX

  1. Install homebrew package manager
  2. Install ruby:
    brew install ruby
    
  3. Install bundler:
    gem install bundler
    
  4. Clone the repo:
    git clone https://github.com/CivicTechWR/WRVotesFed.git
    
  5. Then go into the WRVotesFed directory, and run install the gems:
    cd WRVotesFed
    bundle install
    
  6. Then start the jekyll server:
    cd docs
    bundle exec jekyll server
    
  7. You should now be able to follow the URL which is displayed and you should see the site. (N.B.: Some elements which are dependent upon the Github API may not be displayed locally.)

How can I help?

See the Issues list, or join the #project_region_vote channel on our slack space: https://civictechwrslack.herokuapp.com/.

Or come to one of our meetups!

You can’t perform that action at this time.