Permalink
Browse files

List 'Plack' in requirements.txt

Previously only modules from the Plack package were listed
(redundantly), and only the first of them (Plack::Builder) was
actually known to the PPM index.  As long as Stackato installed all
dependencies in the order they are listed in requirements.txt this
works fine, because the PPM client then notices that
Plack::App::URLMap and Plack::App::WrapCGI were already installed by
the Plack::Builder dependency.

In Stackato 0.7 and later PPM will evaluate all requirements in
parallel, so the fact that P::A::URLMap and P::A::WrapCGI are not
included in the PPM database throws an error.

See also: http://bugs.activestate.com/show_bug.cgi?id=92110
  • Loading branch information...
1 parent 24cc925 commit 0ffbe918d07f0804304149a684ebbba6539ba267 @jandubois jandubois committed Jan 14, 2012
Showing with 1 addition and 3 deletions.
  1. +1 −3 requirements.txt
View
@@ -9,9 +9,7 @@ Email::Send
Email::MIME
Template::
URI
-Plack::Builder
-Plack::App::WrapCGI
-Plack::App::URLMap
+Plack
CGI::Emulate::PSGI
CGI::Compile

0 comments on commit 0ffbe91

Please sign in to comment.