Skip to content
Newer
Older
100644 47 lines (38 sloc) 2.06 KB
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
1 # -*- encoding: utf-8 -*-
adb053f @alloy Fix two warnings on Ruby 1.8.7. Closes #475.
alloy authored Aug 25, 2012
2 $:.unshift File.expand_path('../lib', __FILE__)
3 require 'cocoapods'
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
4
5 Gem::Specification.new do |s|
6 s.name = "cocoapods"
478c140 @alloy Add a version constant and print it with --version.
alloy authored Sep 17, 2011
7 s.version = Pod::VERSION
55ef0c4 @alloy Update gemspec and license year.
alloy authored Feb 22, 2012
8 s.date = Date.today
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
9 s.license = "MIT"
8f1bfd7 @alloy Credit where credit is due. Fabio, thanks for all the work!
alloy authored Oct 2, 2012
10 s.email = ["eloy.de.enige@gmail.com", "fabiopelosin@gmail.com"]
7945c24 @floere Renamed links to alloy/cocoapods to CocoaPods/CocoaPods and also allo…
floere authored Nov 12, 2011
11 s.homepage = "https://github.com/CocoaPods/CocoaPods"
8f1bfd7 @alloy Credit where credit is due. Fabio, thanks for all the work!
alloy authored Oct 2, 2012
12 s.authors = ["Eloy Duran", "Fabio Pelosin"]
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
13
55ef0c4 @alloy Update gemspec and license year.
alloy authored Feb 22, 2012
14 s.summary = "An Objective-C library package manager."
91ef6aa @alloy Update gemspec.
alloy authored Nov 12, 2011
15 s.description = "CocoaPods manages library dependencies for your Xcode project.\n\n" \
16 "You specify the dependencies for your project in one easy text file. " \
17 "CocoaPods resolves dependencies between libraries, fetches source " \
18 "code for the dependencies, and creates and maintains an Xcode " \
19 "workspace to build your project.\n\n" \
20 "Ultimately, the goal is to improve discoverability of, and engagement " \
21 "in, third party open-source libraries, by creating a more centralized " \
22 "ecosystem."
4ea18df @alloy Add an extended description to gemspec.
alloy authored Sep 17, 2011
23
bb3535a @alloy Release 0.3.0
alloy authored Nov 13, 2011
24 s.files = Dir["lib/**/*.rb"] + %w{ bin/pod README.md LICENSE CHANGELOG.md }
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
25
26 s.executables = %w{ pod }
27 s.require_paths = %w{ lib }
28
5fe3e52 @fabiopelosin Bump Xcodeproj.
fabiopelosin authored Oct 2, 2012
29 s.add_runtime_dependency 'xcodeproj', '>= 0.3.4'
332ac11 @fabiopelosin [Gemspec] Bump dependency of Xcodeproj.
fabiopelosin authored Sep 10, 2012
30
f70d430 @fabiopelosin Added ActiveSupport as dependency.
fabiopelosin authored Jul 6, 2012
31 s.add_runtime_dependency 'faraday', '~> 0.8.1'
829a374 @fabiopelosin [Gemspec] Depend on Octokit 1.x and bundle update.
fabiopelosin authored Aug 31, 2012
32 s.add_runtime_dependency 'octokit', '~> 1.7'
f70d430 @fabiopelosin Added ActiveSupport as dependency.
fabiopelosin authored Jul 6, 2012
33 s.add_runtime_dependency 'colored', '~> 1.2'
34 s.add_runtime_dependency 'escape', '~> 0.0.4'
35 s.add_runtime_dependency 'json', '~> 1.7.3'
36 s.add_runtime_dependency 'open4', '~> 1.3.0'
37 s.add_runtime_dependency 'rake', '~> 0.9.0'
38 s.add_runtime_dependency 'activesupport', '~> 3.2.6'
223ef73 @alloy Add `json` and `octokit` gems.
alloy authored May 28, 2012
39
70ca382 @mk Re-add bacon development dependency
mk authored Feb 20, 2012
40 s.add_development_dependency 'bacon', '~> 1.1'
5129dcd @alloy Add ActiveSupport dependencies to gemspec.
alloy authored Nov 5, 2011
41
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored Sep 17, 2011
42 ## Make sure you can build the gem on older versions of RubyGems too:
43 s.rubygems_version = "1.6.2"
44 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
45 s.specification_version = 3 if s.respond_to? :specification_version
46 end
Something went wrong with that request. Please try again.