Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 55 lines (46 sloc) 2.681 kB
11a0bd6 @fabiopelosin [Gemspec] Fix encoding issues
fabiopelosin authored
1 # encoding: UTF-8
a13aa84 @fabiopelosin Link the version to CocoaPods-core in a more robust way.
fabiopelosin authored
2 require File.expand_path('../lib/cocoapods/gem_version', __FILE__)
2a54cbe @fabiopelosin [Gemspec] Fix for Ruby 2.0.0-p0
fabiopelosin authored
3 require 'date'
60d127d @fabiopelosin Use the version of CocoaPods-Core.
fabiopelosin authored
4
a13aa84 @fabiopelosin Link the version to CocoaPods-core in a more robust way.
fabiopelosin authored
5 Gem::Specification.new do |s|
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
6 s.name = "cocoapods"
a13aa84 @fabiopelosin Link the version to CocoaPods-core in a more robust way.
fabiopelosin authored
7 s.version = Pod::VERSION
55ef0c4 @alloy Update gemspec and license year.
alloy authored
8 s.date = Date.today
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
9 s.license = "MIT"
5d8fef4 @orta Update LICENSE
orta authored
10 s.email = ["eloy.de.enige@gmail.com", "fabiopelosin@gmail.com", "kyle@fuller.li", "segiddins@segiddins.me"]
7945c24 @floere Renamed links to alloy/cocoapods to CocoaPods/CocoaPods and also allo…
floere authored
11 s.homepage = "https://github.com/CocoaPods/CocoaPods"
5d8fef4 @orta Update LICENSE
orta authored
12 s.authors = ["Eloy Duran", "Fabio Pelosin", "Kyle Fuller", "Samuel Giddins"]
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
13
f4ac6ad @neonichu Objective-C, pfffft...
neonichu authored
14 s.summary = "The Cocoa library package manager."
91ef6aa @alloy Update gemspec.
alloy authored
15 s.description = "CocoaPods manages library dependencies for your Xcode project.\n\n" \
16 "You specify the dependencies for your project in one easy text file. " \
17 "CocoaPods resolves dependencies between libraries, fetches source " \
18 "code for the dependencies, and creates and maintains an Xcode " \
19 "workspace to build your project.\n\n" \
20 "Ultimately, the goal is to improve discoverability of, and engagement " \
21 "in, third party open-source libraries, by creating a more centralized " \
22 "ecosystem."
4ea18df @alloy Add an extended description to gemspec.
alloy authored
23
fedfd05 @fabiopelosin [Gemspec] Remove post install message
fabiopelosin authored
24 s.files = Dir["lib/**/*.rb"] + %w{ bin/pod bin/sandbox-pod README.md LICENSE CHANGELOG.md }
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
25
fcf59b4 @fabiopelosin [Gemspec] Make sandbox-pod executable visible
fabiopelosin authored
26 s.executables = %w{ pod sandbox-pod }
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
27 s.require_paths = %w{ lib }
28
a13aa84 @fabiopelosin Link the version to CocoaPods-core in a more robust way.
fabiopelosin authored
29 # Link with the version of CocoaPods-Core
ad13bd6 @fabiopelosin [Gemspec] Switch back to cocoapods-try in favour of the release fix
fabiopelosin authored
30 s.add_runtime_dependency 'cocoapods-core', "= #{Pod::VERSION}"
27c28e6 @segiddins [gemspec] Bump CLAide to `~> 0.9.1`
segiddins authored
31 s.add_runtime_dependency 'claide', '~> 0.9.1'
8598428 @segiddins [gemspec] Bump Xcodeproj to `~> 0.26.3`
segiddins authored
32 s.add_runtime_dependency 'xcodeproj', '~> 0.26.3'
b91161e @segiddins [gemspec] Bump cocoapods-downloader to `~> 0.9.1`
segiddins authored
33 s.add_runtime_dependency 'cocoapods-downloader', '~> 0.9.1'
5b9d288 @segiddins [Gemspec] Bump cocoapods-plugins to ~> 0.4.2
segiddins authored
34 s.add_runtime_dependency 'cocoapods-plugins', '~> 0.4.2'
8a30545 @segiddins [gemspec] Bump cocoapods-stats to `~> 0.5.3`
segiddins authored
35 s.add_runtime_dependency 'cocoapods-stats', '~> 0.5.3'
bbf562d @segiddins [Gemspec] Update cocoapods-try to ~> 0.4.5
segiddins authored
36 s.add_runtime_dependency 'cocoapods-try', '~> 0.4.5'
68473cc @segiddins [Gemspec] Update cocoapods-trunk to ~> 0.6.1
segiddins authored
37 s.add_runtime_dependency 'cocoapods-trunk', '~> 0.6.1'
18b9760 @segiddins [gemspec] Bump Molinillo to `~> 0.3.1`
segiddins authored
38 s.add_runtime_dependency 'molinillo', '~> 0.3.1'
332ac11 @fabiopelosin [Gemspec] Bump dependency of Xcodeproj.
fabiopelosin authored
39
f70d430 @fabiopelosin Added ActiveSupport as dependency.
fabiopelosin authored
40 s.add_runtime_dependency 'colored', '~> 1.2'
41 s.add_runtime_dependency 'escape', '~> 0.0.4'
fc74853 @alloy Drop support for Ruby < 2.0.0
alloy authored
42 s.add_runtime_dependency 'activesupport', '>= 3.2.15'
11d6e76 @segiddins [Gemspec] Update to nap 0.8
segiddins authored
43 s.add_runtime_dependency 'nap', '~> 0.8'
223ef73 @alloy Add `json` and `octokit` gems.
alloy authored
44
7e68c66 @fabiopelosin [Gemspec] Add dev dependency on Rake
fabiopelosin authored
45 s.add_development_dependency 'bundler', '~> 1.3'
46 s.add_development_dependency 'rake'
70ca382 @mk Re-add bacon development dependency
mk authored
47 s.add_development_dependency 'bacon', '~> 1.1'
5129dcd @alloy Add ActiveSupport dependencies to gemspec.
alloy authored
48
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
49 ## Make sure you can build the gem on older versions of RubyGems too:
50 s.rubygems_version = "1.6.2"
51 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
4d84a4f @kylef Drop support for Ruby 1.8.7
kylef authored
52 s.required_ruby_version = '>= 2.0.0'
5ae76e2 @alloy Add a gemspec for cocoapods itself.
alloy authored
53 s.specification_version = 3 if s.respond_to? :specification_version
54 end
Something went wrong with that request. Please try again.