Skip to content
This repository
Fetching contributors…

Cannot retrieve contributors at this time

file 50 lines (42 sloc) 2.371 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
# -*- encoding: utf-8 -*-
require File.expand_path('../lib/cocoapods/gem_version', __FILE__)
require 'date'

Gem::Specification.new do |s|
  s.name = "cocoapods"
  s.version = Pod::VERSION
  s.date = Date.today
  s.license = "MIT"
  s.email = ["eloy.de.enige@gmail.com", "fabiopelosin@gmail.com"]
  s.homepage = "https://github.com/CocoaPods/CocoaPods"
  s.authors = ["Eloy Duran", "Fabio Pelosin"]

  s.summary = "An Objective-C library package manager."
  s.description = "CocoaPods manages library dependencies for your Xcode project.\n\n" \
                  "You specify the dependencies for your project in one easy text file. " \
                  "CocoaPods resolves dependencies between libraries, fetches source " \
                  "code for the dependencies, and creates and maintains an Xcode " \
                  "workspace to build your project.\n\n" \
                  "Ultimately, the goal is to improve discoverability of, and engagement " \
                  "in, third party open-source libraries, by creating a more centralized " \
                  "ecosystem."

  s.files = Dir["lib/**/*.rb"] + %w{ bin/pod README.md LICENSE CHANGELOG.md }

  s.executables = %w{ pod }
  s.require_paths = %w{ lib }

  # Link with the version of CocoaPods-Core
  s.add_runtime_dependency 'cocoapods-core', "= #{Pod::VERSION}"
  s.add_runtime_dependency 'claide', '~> 0.2.0'
  s.add_runtime_dependency 'cocoapods-downloader', '~> 0.1.0'
  s.add_runtime_dependency 'xcodeproj', '~> 0.5.2'

  s.add_runtime_dependency 'faraday', '~> 0.8.1'
  s.add_runtime_dependency 'octokit', '~> 1.7'
  s.add_runtime_dependency 'colored', '~> 1.2'
  s.add_runtime_dependency 'escape', '~> 0.0.4'
  s.add_runtime_dependency 'json', '~> 1.7.3'
  s.add_runtime_dependency 'open4', '~> 1.3.0'
  s.add_runtime_dependency 'rake', '~> 10.0.0'
  s.add_runtime_dependency 'activesupport', '~> 3.2.13'

  s.add_development_dependency 'bacon', '~> 1.1'

  ## Make sure you can build the gem on older versions of RubyGems too:
  s.rubygems_version = "1.6.2"
  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.specification_version = 3 if s.respond_to? :specification_version
end
Something went wrong with that request. Please try again.