Browse files

Use last version of faraday that doesn't complain about `system_timer…

…` gem missing.
  • Loading branch information...
1 parent 356216d commit 11ecc3a5702c96fee00579c2bb884d44aee68f50 @alloy alloy committed May 28, 2012
Showing with 25 additions and 7 deletions.
  1. +8 −1 Gemfile
  2. +9 −5 Gemfile.lock
  3. +8 −1 cocoapods.gemspec
View
9 Gemfile
@@ -4,7 +4,14 @@ gem "colored"
gem "escape"
gem "json"
gem "open4"
-gem "octokit"
+
+# We don't want octokit to pull in faraday 0.8.0, as it prints a warning about
+# the `system_timer` gem being needed, which isn't available on 1.9.x
+#
+# Once faraday 0.8.1 is released this should be resolved:
+# https://github.com/technoweenie/faraday/pull/147
+gem "faraday", "0.7.6"
+gem "octokit", "<= 1.0.3"
group :development do
gem "xcodeproj", :git => "git://github.com/CocoaPods/Xcodeproj.git"
View
14 Gemfile.lock
@@ -14,8 +14,10 @@ GEM
colored (1.2)
crack (0.3.1)
escape (0.0.4)
- faraday (0.8.0)
+ faraday (0.7.6)
+ addressable (~> 2.2)
multipart-post (~> 1.1)
+ rack (~> 1.1)
faraday_middleware (0.8.7)
faraday (>= 0.7.4, < 0.9)
hashie (1.2.0)
@@ -28,11 +30,11 @@ GEM
metaclass (~> 0.0.1)
mocha-on-bacon (0.2.0)
mocha (>= 0.9.8)
- multi_json (1.3.5)
+ multi_json (1.3.6)
multipart-post (1.1.5)
- octokit (1.3.0)
+ octokit (1.0.3)
addressable (~> 2.2)
- faraday (~> 0.8)
+ faraday (~> 0.7)
faraday_middleware (~> 0.8)
hashie (~> 1.2)
multi_json (~> 1.3)
@@ -41,6 +43,7 @@ GEM
coderay (~> 1.0.5)
method_source (~> 0.7.1)
slop (>= 2.4.4, < 3)
+ rack (1.4.1)
rake (0.9.2.2)
rb-fsevent (0.9.1)
slop (2.4.4)
@@ -57,10 +60,11 @@ DEPENDENCIES
bacon
colored
escape
+ faraday (= 0.7.6)
json
kicker
mocha-on-bacon
- octokit
+ octokit (<= 1.0.3)
open4
pry
rake
View
9 cocoapods.gemspec
@@ -28,10 +28,17 @@ Gem::Specification.new do |s|
s.post_install_message = "[!] If this is your first time install of CocoaPods, or if " \
"you are upgrading, first run: $ pod setup"
+ # We don't want octokit to pull in faraday 0.8.0, as it prints a warning about
+ # the `system_timer` gem being needed, which isn't available on 1.9.x
+ #
+ # Once faraday 0.8.1 is released this should be resolved:
+ # https://github.com/technoweenie/faraday/pull/147
+ s.add_runtime_dependency 'faraday', '~> 0.7.6'
+ s.add_runtime_dependency 'octokit', '<= 1.0.3'
+
s.add_runtime_dependency 'colored', '~> 1.2'
s.add_runtime_dependency 'escape', '~> 0.0.4'
s.add_runtime_dependency 'json', '~> 1.7.3'
- s.add_runtime_dependency 'octokit', '~> 1.3.0'
s.add_runtime_dependency 'open4', '~> 1.3.0'
s.add_runtime_dependency 'rake', '~> 0.9.0'
s.add_runtime_dependency 'xcodeproj', '~> 0.1.0' # TODO update to RC1 for 0.6.0.rc1

0 comments on commit 11ecc3a

Please sign in to comment.