Permalink
Browse files

Fix RubyGems version informative crash.

Closes #570
  • Loading branch information...
1 parent 8f1bfd7 commit 4b3497233a4523711567447fffbdc0e954aa491d @fabiopelosin fabiopelosin committed Oct 3, 2012
Showing with 5 additions and 1 deletion.
  1. +4 −0 CHANGELOG.md
  2. +1 −1 lib/cocoapods.rb
View
@@ -2,6 +2,10 @@
[CocoaPods](https://github.com/CocoaPods/CocoaPods/compare/0.15.0...master)
+###### Bug fixes
+- Fixed a crash related to the RubyGems version informative.
+ [#570](https://github.com/CocoaPods/CocoaPods/issues/570)
+
## 0.15.0
[CocoaPods](https://github.com/CocoaPods/CocoaPods/compare/0.14.0...0.15.0) • [Xcodeproj](https://github.com/CocoaPods/Xcodeproj/compare/0.3.3...0.3.4)
View
@@ -7,7 +7,7 @@
#
# E.g. https://github.com/CocoaPods/CocoaPods/issues/398
unless Gem::Version::Requirement.new('>= 1.4.0').satisfied_by?(Gem::Version.new(Gem::VERSION))
- STDERR.puts "Your RubyGems version (#{Gem::VERSION}) is too old, please update with: `gem update --system`".red
+ STDERR.puts "\e[1;31m" + "Your RubyGems version (1.8.24) is too old, please update with: `gem update --system`" + "\e[0m"
exit 1
end

1 comment on commit 4b34972

MSch commented on 4b34972 Oct 4, 2012

Ha, I experienced that just 5 seconds ago :)

Please sign in to comment.