Permalink
Browse files

Clean up a bit.

  • Loading branch information...
1 parent 7cb1c5b commit 5ddd18fdfd53faa107bec126b3ee51a4b6e7a562 @alloy alloy committed Sep 20, 2011
Showing with 8 additions and 31 deletions.
  1. +8 −6 examples/{PodSpec.podspec → IdeasExample.podspec}
  2. +0 −25 examples/Podfile
@@ -1,8 +1,15 @@
-class IcePop < Pod::Spec
+# NOTE: This is a spec with a lot of ideas I had that _could_ possibly ever be
+# added. So this list should, for now, not be taken as all the current
+# possibilities.
+
+Pod::Spec.new do
#############################################################################
# Required attributes
#############################################################################
+ # This pod’s name.
+ name 'IcePop'
+
# This pod’s version.
#
# The version string can contain numbers and periods, such as 1.0.0. A pod is
@@ -32,11 +39,6 @@ class IcePop < Pod::Spec
# Optional attributes
#############################################################################
- # This pod’s name.
- #
- # It default to the name of the manifest class.
- name 'IcePop'
-
# A long description of this pod. It should be more detailed than the summary.
#
# It defaults to the summary.
View
@@ -1,25 +0,0 @@
-dependency 'Kiwi'
-
-#dependency 'doesnotexist'
-
-#dependency 'SSZipArchive'
-
-#dependency 'ASIHTTPRequest', '1.8'
-#dependency 'ASIWebPageRequest', '= 1.8'
-
-# is part of ASIHTTPRequest 1.8 and 1.8.1
-#dependency 'Reachability' #, '>= 2.0'
-
-# is part of ASIHTTPRequest
-#dependency 'ASIWebPageRequest', '>= 1.8'
-#dependency 'ASIWebPageRequest', '= 1.8'
-
-# this should fail the ASIHTTPRequest 1.8.1 hard requirement
-#dependency 'ASIWebPageRequest', '1.8.0'
-
-# we have a hard requirement here so:
-# * the Reachability dependency should be taken from this version
-# * the ASIWebPageRequest dependency requirement matches this one so should work
-#dependency 'ASIHTTPRequest', '1.8.1'
-#dependency 'ASIHTTPRequest', '>= 1.8'
-

0 comments on commit 5ddd18f

Please sign in to comment.