Permalink
Browse files

[Outdated] Fixed crash.

Closes 568.
  • Loading branch information...
1 parent 8e72cbe commit 918167250b369fd750463cbb42327a460d2fb5ac @fabiopelosin fabiopelosin committed Oct 4, 2012
Showing with 5 additions and 1 deletion.
  1. +2 −0 CHANGELOG.md
  2. +3 −1 lib/cocoapods/command/outdated.rb
View
@@ -9,6 +9,8 @@
[#568](https://github.com/CocoaPods/CocoaPods/issues/568)
- Fixed a crash related to the RubyGems version informative.
[#570](https://github.com/CocoaPods/CocoaPods/issues/570)
+- Fixed a crash for `pod outdated`.
+ [#567](https://github.com/CocoaPods/CocoaPods/issues/567)
## 0.15.0
@@ -22,14 +22,16 @@ def initialize(argv)
def run
verify_podfile_exists!
verify_lockfile_exists!
- update_spec_repos_if_necessary!
sandbox = Sandbox.new(config.project_pods_root)
resolver = Resolver.new(config.podfile, config.lockfile, sandbox)
resolver.update_mode = true
resolver.update_external_specs = false
resolver.resolve
+ #TODO: the command report new dependencies (added to by updated ones)
+ # as updates.
+
names = resolver.pods_to_install - resolver.pods_from_external_sources
specs = resolver.specs.select do |spec|
names.include?(spec.name) && !spec.version.head?

0 comments on commit 9181672

Please sign in to comment.