Permalink
Browse files

Merge branch 'master' into pod_update

* master:
  Updated installation notes.
  [Gemfile.lock] update.
  Release 0.11.0
  [Rakefile] fine tuned release task.
  [CHANGELOG] Updated.
  fixing path on push command documentation description
  updating description for pod push with more detail about how it works
  • Loading branch information...
2 parents c290bf9 + 0821ad2 commit ea632ada83b079ff654a2f9f566bd94a0e9a2529 @fabiopelosin fabiopelosin committed Aug 9, 2012
Showing with 13 additions and 9 deletions.
  1. +4 −3 CHANGELOG.md
  2. +1 −1 Gemfile.lock
  3. +2 −1 README.md
  4. +1 −0 Rakefile
  5. +1 −1 lib/cocoapods.rb
  6. +4 −3 lib/cocoapods/command/push.rb
View
@@ -1,18 +1,19 @@
-## 0.10.1
+## 0.11.0
[CocoaPods](https://github.com/CocoaPods/CocoaPods/compare/0.10.0...master)
###### Enhancements
+- Added support for public headers. [#440]
- Added `pod repo lint`. [#423]
- Improved support for `:head` option and svn repositories.
- When integrating Pods with a project without "Frameworks" group in root of the project, raise an informative message. [#431](https://github.com/CocoaPods/CocoaPods/pull/431)
- Dropped support for legacy `config.ios?` and `config.osx?`
###### Bug fixes
-- Version message terminates with 0 exit status.
-- Don't output git error messages in the error report if there are no repos or if a repo is not under git source control.
+- Version message now correctly terminates with a 0 exit status.
+- Resolved an issue that lead to git error messages in the error report.
## 0.10.0
View
@@ -17,7 +17,7 @@ GIT
PATH
remote: .
specs:
- cocoapods (0.10.0)
+ cocoapods (0.11.0)
activesupport (~> 3.2.6)
colored (~> 1.2)
escape (~> 0.0.4)
View
@@ -41,7 +41,8 @@ Now that you've got CocoaPods installed you can easily add it to your project.
**NOTES**
-1. If you're using a fresh out of the box Mac with Lion using Xcode from the Mac App Store, you will need to install the Command Line Tools for Xcode first: [here](https://developer.apple.com/downloads/index.action)
+1. If you're using a fresh out of the box Mac with Lion using Xcode from the Mac App Store, you will need to install the Command Line Tools for Xcode first: [here](https://developer.apple.com/downloads/index.action)
+Or from `Xcode > Settings > Downloads > Components > Command Line Tools`
2. CocoaPods re-uses some of the RubyGems classes. If you have a version older than 1.4.0, you will have to update RubyGems: `$ gem update --system`.
View
@@ -99,6 +99,7 @@ namespace :gem do
exit 1
end
+ diff_lines.delete('Gemfile.lock')
if diff_lines != ['lib/cocoapods.rb']
$stderr.puts "[!] Only change the version number in a release commit!"
exit 1
View
@@ -13,7 +13,7 @@
end
module Pod
- VERSION = '0.10.0'
+ VERSION = '0.11.0'
class PlainInformative < StandardError
end
@@ -8,9 +8,10 @@ def self.banner
$ pod push REPO [NAME.podspec]
- Validates NAME.podspec or `*.podspec' in the current working dir, updates
- the local copy of the repository named REPO, adds the specifications
- to the REPO, and finally it pushes REPO to its remote.}
+ Validates NAME.podspec or `*.podspec' in the current working dir, creates
+ a directory and version folder for the pod in the local copy of
+ REPO (~/.cocoapods/[REPO]), copies the podspec file into the version directory,
+ and finally it pushes REPO to its remote.}
end
def self.options

0 comments on commit ea632ad

Please sign in to comment.