Skip to content
This repository

Mar 19, 2013

  1. Fabio Pelosin

    [Validator] Clean up

    irrationalfab authored
  2. Fabio Pelosin

    [Repo::Lint] Update for CocoaPods-Core changes

    irrationalfab authored

Mar 18, 2013

  1. Fabio Pelosin

    [Coveralls] Preliminary support

    irrationalfab authored

Mar 01, 2013

  1. Fabio Pelosin

    [Gemfile] Point to repos instead of to gems

    irrationalfab authored

Feb 27, 2013

  1. Fabio Pelosin

    Update outdated dependencies

    irrationalfab authored

Feb 25, 2013

  1. Fabio Pelosin

    [Gemfile] Use gemspec versions

    irrationalfab authored

Feb 12, 2013

  1. Fabio Pelosin

    Merge branch 'integration_take_2' into integration_take_2_0_17_test

    * integration_take_2:
      [Specs Integration] Clean implementation a bit.
      [TargetInstaller] Sort headers in xcconfig.
      [Bundle] update
      Add .hg folders to specs repos
      [Gitignore] Don't ignore .hg folders
      [Specs Integration] Added more tests.
      [Specs Integration] Clean up implementation.
      [Specs Integration] Skip unreliable tests.
      [Installer] Don't show using existing documentation message if docs should be skipped
      [Specs] Added integration specs
      [Specs Integration] Add check for output.
      Integrations tests part 2
    
    Conflicts:
    	.gitignore
    	Gemfile.lock
    	lib/cocoapods/installer.rb
    	lib/cocoapods/installer/target_installer.rb
    irrationalfab authored

Feb 09, 2013

  1. Fabio Pelosin

    Integrations tests part 2

    irrationalfab authored

Dec 17, 2012

  1. Fabio Pelosin

    Extracted Analyzer class from installer.

    - added support for manifest.lock.
    - added support for checking specifications checksums.
    - removed lazy repo update as the check for the specifications checksums
      requires an up to date repo.
    
    Closes #604.
    irrationalfab authored

Dec 14, 2012

  1. Fabio Pelosin

    [Config] Complete clean up.

    irrationalfab authored

Dec 13, 2012

  1. Fabio Pelosin

    [UI] Redirect cocoapdods-core UI & send warnings to STDERR & improve …

    …support in specs.
    irrationalfab authored

Dec 12, 2012

  1. Fabio Pelosin

    Extracted downloader.

    irrationalfab authored

Dec 06, 2012

  1. Fabio Pelosin

    Improved support for CocoaPods-Core version.

    irrationalfab authored
  2. Fabio Pelosin

    Use the version of CocoaPods-Core.

    irrationalfab authored

Dec 05, 2012

  1. Fabio Pelosin

    Fixes for core changes.

    irrationalfab authored

Nov 29, 2012

  1. Fabio Pelosin

    [Rake] Added docs support.

    irrationalfab authored

Nov 22, 2012

  1. Fabio Pelosin

    [Gemfile] Use WebMock >= 1.8.0, < 1.9 as requested by VCR.

    irrationalfab authored

Nov 13, 2012

  1. Fabio Pelosin

    [Core Extraction] Initial support for CocoaPods-Core.

    irrationalfab authored

Oct 21, 2012

  1. Fabio Pelosin

    Require Xcodeproj 0.4.0.rc1

    irrationalfab authored

Oct 20, 2012

  1. Fabio Pelosin

    [Gemfile] Use Xcodeproj refactor branch.

    irrationalfab authored

Oct 19, 2012

  1. Fabio Pelosin

    [Gemfile] Install and remove dependency on letters gem.

    Letters was causing issues with the colored gem and apparently is not supported
    on 1.8.7.
    irrationalfab authored

Oct 04, 2012

  1. Fabio Pelosin

    Travis use only development gems.

    irrationalfab authored
  2. Fabio Pelosin

    [Gemfile] Use letters for debugging.

    irrationalfab authored

Aug 07, 2012

  1. Fabio Pelosin

    [Gemfile] pointed kicker to the head of the 3.0.0 branch.

    irrationalfab authored

Jul 23, 2012

  1. Eloy Durán

    Clean pods *after* resolving and activating. Fixes #414.

    alloy authored

Jul 09, 2012

  1. Eloy Durán

    Update bundle.

    alloy authored

Jul 06, 2012

  1. Fabio Pelosin

    [Gemfile] Lock Bacon to 0.11.x.

Jun 25, 2012

  1. Fabio Pelosin

    [Gemfile] Use dependencies directly from gemspec.

Jun 07, 2012

  1. Fabio Pelosin

    [Docs] Preliminary support for YARD.

Jun 05, 2012

  1. Eloy Durán

    Update bundle.

    alloy authored

May 29, 2012

  1. Eloy Durán

    Silence warnings while loading Faraday for Octokit. See #278.

    alloy authored

May 28, 2012

  1. Eloy Durán

    Use last version of faraday that doesn't complain about `system_timer…

    …` gem missing.
    alloy authored
  2. Eloy Durán

    Add `json` and `octokit` gems.

    Wanted to add `system_timer` but it doesn't build on 1.9.3.
    
    Closes #278. At least for now.
    alloy authored
  3. Eloy Durán

    Use Open4 in Executable. Indenter code by @ahoward, thanks!

    alloy authored

Apr 23, 2012

  1. Fabio Pelosin

    Removed unused popen4 dependency

    irrationalfab authored
Something went wrong with that request. Please try again.