New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

While Installing cocoaPods Getting error #1299

Closed
paradigm-creatives opened this Issue Aug 19, 2013 · 8 comments

Comments

Projects
None yet
5 participants
@paradigm-creatives

paradigm-creatives commented Aug 19, 2013

Recently i have updated my os to 10.8.4 now i cant install pods getting error with facebook,can you please give your valuable suggetsion.

Stack

   CocoaPods : 0.20.2
        Ruby : ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-darwin12.2.0]
    RubyGems : 2.0.7
        Host : Mac OS X 10.8.4 (12E55)
       Xcode : 4.6.3 (4H1503)
Ruby lib dir : /Users/prasadb/.rvm/rubies/ruby-2.0.0-p195/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 8335ca4ca348bbd8b06ae1f203a5c71fbf9b0691

Podfile

platform :ios, '4.3'

pod 'Facebook-iOS-SDK', "~> 3.0.7"
pod 'GoogleAnalytics-iOS-SDK', "~> 1.4"
pod 'GDataXML-HTML'
pod 'AdMob', "~> 6.4.2"

xcodeproj 'HorseRacesNow.xcodeproj'

Error

Pod::DSLError - Invalid `Facebook-iOS-SDK.podspec` file: undefined method `prepare_command=' for #<Pod::Specification name="Facebook-iOS-SDK">
 #
 #  from /Users/prasadb/.cocoapods/master/Facebook-iOS-SDK/3.7.0/Facebook-iOS-SDK.podspec:16
 #  -------------------------------------------
 #    s.framework = 'CoreLocation'
 >    s.prepare_command = "find src -name \\*.png | grep -v @ | grep -v -- - | sed -e 's|\\(.*\\)/\\([a-zA-Z0-9]*\\).png|python scripts/image_to_code.py -i \\1/\\2.png -c \\2 -o src|' | sh"
 #  end
 #  -------------------------------------------
 #
/Users/prasadb/.cocoapods/master/Facebook-iOS-SDK/3.7.0/Facebook-iOS-SDK.podspec:16:in `block in _eval_podspec'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification.rb:40:in `initialize'
/Users/prasadb/.cocoapods/master/Facebook-iOS-SDK/3.7.0/Facebook-iOS-SDK.podspec:1:in `new'
/Users/prasadb/.cocoapods/master/Facebook-iOS-SDK/3.7.0/Facebook-iOS-SDK.podspec:1:in `_eval_podspec'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification.rb:608:in `eval'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification.rb:608:in `_eval_podspec'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification.rb:558:in `from_string'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification.rb:541:in `from_file'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/specification/set.rb:88:in `specification'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source.rb:156:in `block in search'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source.rb:151:in `each'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source.rb:151:in `find'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source.rb:151:in `search'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source/aggregate.rb:104:in `block in search'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source/aggregate.rb:104:in `select'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-core-0.20.2/lib/cocoapods-core/source/aggregate.rb:104:in `search'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:191:in `find_cached_set'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:153:in `block (2 levels) in find_dependency_specs'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/user_interface.rb:113:in `message'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:152:in `block in find_dependency_specs'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:148:in `each'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:148:in `find_dependency_specs'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:65:in `block (2 levels) in resolve'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/user_interface.rb:52:in `section'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:63:in `block in resolve'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:62:in `each'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/resolver.rb:62:in `resolve'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer/analyzer.rb:290:in `block in resolve_dependencies'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/user_interface.rb:52:in `section'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer/analyzer.rb:288:in `resolve_dependencies'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer/analyzer.rb:56:in `analyze'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer.rb:167:in `analyze'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer.rb:92:in `block in resolve_dependencies'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/user_interface.rb:52:in `section'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer.rb:91:in `resolve_dependencies'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/installer.rb:84:in `install!'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/command/project.rb:38:in `run_install_with_update'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/command/project.rb:68:in `run'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/claide-0.3.2/lib/claide/command.rb:206:in `run'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/lib/cocoapods/command.rb:49:in `run'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/gems/cocoapods-0.20.2/bin/pod:19:in `<top (required)>'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/bin/pod:23:in `load'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/bin/pod:23:in `<main>'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/bin/ruby_noexec_wrapper:14:in `eval'
/Users/prasadb/.rvm/gems/ruby-2.0.0-p195/bin/ruby_noexec_wrapper:14:in `<main>'

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.

Search for existing github issues similar to yours:
https://github.com/CocoaPods/CocoaPods/search?q=Invalid+%60Facebook-iOS-SDK.podspec%60+file%3A+undefined+method+%60prepare_command%3D%27+for+%23%3CPod%3A%3ASpecification+name%3D%22Facebook-iOS-SDK%22%3E%0A+%23%0A+%23++from+%2FUsers%2Fprasadb%2F.cocoapods%2Fmaster%2FFacebook-iOS-SDK%2F3.7.0%2FFacebook-iOS-SDK.podspec%3A16%0A+%23++-------------------------------------------%0A+%23++++s.framework+%3D+%27CoreLocation%27%0A+%3E++++s.prepare_command+%3D+%22find+src+-name+%5C%5C%2A.png+%7C+grep+-v+%40+%7C+grep+-v+--+-+%7C+sed+-e+%27s%7C%5C%5C%28.%2A%5C%5C%29%2F%5C%5C%28%5Ba-zA-Z0-9%5D%2A%5C%5C%29.png%7Cpython+scripts%2Fimage_to_code.py+-i+%5C%5C1%2F%5C%5C2.png+-c+%5C%5C2+-o+src%7C%27+%7C+sh%22%0A+%23++end%0A+%23++-------------------------------------------%0A+%23&type=Issues

Thanks in advance,
Girish

@misterHallodri

This comment has been minimized.

misterHallodri commented Aug 19, 2013

I got the same issue since friday as there was an update for the facebook pod. :/ will post a solution here if I find something.

@misterHallodri

This comment has been minimized.

misterHallodri commented Aug 19, 2013

updating the cocapods gem fixed it locally (need to verify on our build server), try that.

@paradigm-creatives

This comment has been minimized.

paradigm-creatives commented Aug 19, 2013

Thanks misterHallodri,I wiill check like that.

@alloy

This comment has been minimized.

Member

alloy commented Aug 19, 2013

As it states in the file that’s shown above the new ticket form, first update your CP version before filing a ticket.

Furthermore, follow the @CocoaPods twitter account for notifications and check the CHANGELOG to keep up-to-date with changes. We do not maintain these resources just for the fun of it.

@alloy alloy closed this Aug 19, 2013

@quanturium

This comment has been minimized.

quanturium commented Aug 19, 2013

@misterHallodri I've got the same issue, how did you fix it? Thanks.

@misterHallodri

This comment has been minimized.

misterHallodri commented Aug 20, 2013

Like I wrote and @alloy stated! Update you Cocoapods version!

@quanturium

This comment has been minimized.

quanturium commented Aug 20, 2013

@misterHallodri Alright, thanks!

@bogardon

This comment has been minimized.

bogardon commented Aug 22, 2013

Why does it throw errors for versions that aren't even specified?

jzapater pushed a commit to jzapater/CocoaPods that referenced this issue Sep 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment