RuntimeError - Build setting `SDKROOT` has multiple values #1463

Closed
deanandreakis opened this Issue Oct 10, 2013 · 3 comments

Comments

Projects
None yet
4 participants

――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

Report

  • What did you do?
  • What did you expect to happen?
  • What happened instead?

Stack

   CocoaPods : 0.26.2
        Ruby : ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]
    RubyGems : 2.0.0
        Host : Mac OS X 10.8.5 (12F45)
       Xcode : 5.0 (5A1412)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ f0353f381bf3228ef460eaf2a5c8ada3f86395b3

Podfile

platform :ios, "7.0"
pod 'AFNetworking', '~>1.3'

Error

RuntimeError - Build setting `SDKROOT` has multiple values: `ReleaseiphoneosDistributionDebugiphoneos`
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:77:in `common_resolved_build_setting'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:84:in `sdk'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:90:in `platform_name'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:252:in `add_system_framework'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:250:in `each'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/object/native_target.rb:250:in `add_system_framework'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project/project_helper.rb:58:in `new_target'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.13.0/lib/xcodeproj/project.rb:576:in `new_target'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer/target_installer.rb:44:in `add_target'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer/target_installer/pod_target_installer.rb:15:in `install!'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/user_interface.rb:113:in `message'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer/target_installer/pod_target_installer.rb:14:in `install!'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:340:in `install_libraries'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:337:in `each'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:337:in `install_libraries'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/user_interface.rb:113:in `message'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:336:in `install_libraries'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:113:in `generate_pods_project'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/user_interface.rb:52:in `section'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:110:in `generate_pods_project'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/installer.rb:88:in `install!'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/command/project.rb:38:in `run_install_with_update'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/command/project.rb:68:in `run'
/Library/Ruby/Gems/1.8/gems/claide-0.3.2/lib/claide/command.rb:206:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/lib/cocoapods/command.rb:51:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.26.2/bin/pod:19
/usr/bin/pod:23:in `load'
/usr/bin/pod:23

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

I just got the same one

fpillet commented Oct 10, 2013

Just updated to 0.26.2 and it broke my build the same way too (don't have the same packages in there)

Owner

orta commented Oct 10, 2013

This is a dupe of #1462 - closing to keep discussion focused

@orta orta closed this Oct 10, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment