Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Pod install ignore podfile.lock's version #1483

Closed
Whirlwind opened this Issue · 8 comments

5 participants

@Whirlwind

I use the google map sdk, and I run pod install, I found the google map sdk be updated!! Why?

git show that (in my Podfile.lock):

 PODS:
-  - Google-Maps-iOS-SDK (1.4.3)
+  - Google-Maps-iOS-SDK (1.5.0)

cocoapods 0.26.2, ruby-1.9.3-p392

@Whirlwind

Here is the pod install --verbose:

Finding Podfile changes
  - JSONKit
  - MYMapChinaShift
  - MYMapKitProtocol
  - MYMapKitProtocol
  - UMengAnalytics

Fetching external sources
-> Fetching podspec for `MYMapChinaShift` from `./plugins/MYMapChinaShift`
-> Fetching podspec for `MYMapKitProtocol` from `./plugins/MYMapKitProtocol`
-> Fetching podspec for `MYMapKitProtocol` from `./plugins/MYMapKitProtocol`

Resolving dependencies of `Podfile`
Resolving dependencies for target `Pods' (iOS 6.0)
  - UMengAnalytics (= 2.2.1)
  - JSONKit (= 1.5pre)
  - MYMapChinaShift (from `./plugins/MYMapChinaShift`)
  - MYMapKitProtocol/AppleMapKit (from `./plugins/MYMapKitProtocol`)
    - MYMapKitProtocol/Core
      - MYMapChinaShift (from `./plugins/MYMapChinaShift`)
  - MYMapKitProtocol/GoogleMapKit (from `./plugins/MYMapKitProtocol`)
    - Google-Maps-iOS-SDK (>= 1.4)
    - SMCalloutView
    - MYMapKitProtocol/Core

Comparing resolved specification to the sandbox manifest
  A Google-Maps-iOS-SDK
  - JSONKit
  - MYMapChinaShift
  - MYMapKitProtocol
  - SMCalloutView
  - UMengAnalytics

Downloading dependencies

-> Installing Google-Maps-iOS-SDK (1.5.0)
.....

I installed Google-Maps-iOS-SDK v1.4.3, but the CP check it need install v1.5.0.

@Whirlwind

Nobody care this issue?

@Whirlwind

I found that the podfile.lock can NOT lock the version in a dependency.

@fabiopelosin

There is another ticket similar to this, the issue is confirmed!

@woahdae

+1, found the same issue.

@woahdae

Version 0.26.2; happy to try a more beta version if there's been a fix recently.

@kreeger

Is this still an issue? I'm using 0.29.0 and both pod and pod install seem to disregard the lock I'm trying to keep in place for CocoaLumberjack, even after I blow away my Pods directory and my Podfile.lock file.

pod 'CocoaLumberjack', '1.6.2'

Running pod or pod install installs 1.8.0 every time.

@kylef
Owner

This is the same issue as #1860, i'm going to close this in favour of that one since it's better explained.

@kylef kylef closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.