Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

How to force install an incompatible pod? #1505

Closed
VincentSit opened this Issue Oct 23, 2013 · 3 comments

Comments

Projects
None yet
2 participants
[!] The platform of the target `Pods` (iOS 5.0) is not compatible with `IDMPhotoBrowser (1.2.6)` which has a minimum requirement of iOS 6.0.
➜  jybb git:(develop) ✗ pod install --force 
[!] Unknown arguments: --force

I know that this pod is not compatible with my project, but I need to force install it, how to do it?

I found the solution:

➜  ~  .cocoapods 
➜  .cocoapods  repos 
➜  repos  master 
➜  master git:(master) IDMPhotoBrowser 
➜  IDMPhotoBrowser git:(master) 1.2.6
➜  1.2.6 git:(master) ls
IDMPhotoBrowser.podspec
➜  1.2.6 git:(master) open IDMPhotoBrowser.podspec 
➜  1.2.6 git:(master) 

I changed the s.platform to 5.0.

@VincentSit VincentSit closed this Oct 23, 2013

Contributor

rivera-ernesto commented Oct 23, 2013

Instead of modifying the podspec you could try #1376.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment