Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Error doing pod install #1628

Closed
ventayol opened this Issue · 3 comments

3 participants

@ventayol

Report

  • What did you do?

I've run pod install. If I remove the last item from link_with everything works fine.

  • What did you expect to happen?

That the pod install finish ok

  • What happened instead?

An error showed

Stack

   CocoaPods : 0.28.0
        Ruby : ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-darwin12.5.0]
    RubyGems : 2.1.5
        Host : Mac OS X 10.9 (13A603)
       Xcode : 5.0.2 (5A3005)
Ruby lib dir : /Users/aleix/.rvm/rubies/ruby-1.9.3-p448/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 4194a50277fe7a42d3c6fe6ae6e014b96b4f1b6c

Podfile

platform :ios, '5.0'

link_with 'TWE FG 2012','TWE FG 2013','TWE FG 2014','The Watch Enthusiast'
pod "OHAttributedLabel"
pod "FlurrySDK"
pod "GoogleAnalytics-iOS-SDK"
pod "MBProgressHUD"
pod "FlurrySDK"
pod "ASIHTTPRequest"
pod "OpenUDID"
pod "TestFlightSDK"

Error

ArgumentError - comparison of String with Array failed
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:467:in `sort'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:467:in `compute_archs_for_target_definition'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:491:in `block in compute_target_platforms'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:485:in `each'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:485:in `compute_target_platforms'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer/analyzer.rb:55:in `analyze'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer.rb:171:in `analyze'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer.rb:94:in `block in resolve_dependencies'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/user_interface.rb:52:in `section'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer.rb:93:in `resolve_dependencies'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/installer.rb:86:in `install!'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/command/project.rb:38:in `run_install_with_update'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/command/project.rb:68:in `run'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/claide-0.4.0/lib/claide/command.rb:213:in `run'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/lib/cocoapods/command.rb:52:in `run'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/gems/cocoapods-0.28.0/bin/pod:24:in `<top (required)>'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/bin/pod:23:in `load'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/bin/pod:23:in `<main>'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/bin/ruby_executable_hooks:15:in `eval'
/Users/aleix/.rvm/gems/ruby-1.9.3-p448/bin/ruby_executable_hooks:15:in `<main>'
@Kapin
Collaborator

This may be related to #1413.

@kylef
Owner

@ventayol I can't reproduce this, are you still having this issue with CocoaPods 0.29.0?

@ventayol

I think it's OK.
I've changed some pods and now everything is working fine.
I close the bug.

@ventayol ventayol closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.