Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

No such file or directory - [Project_Path]/Pods/Pods.xcconfig #163

Closed
D1plo1d opened this Issue · 14 comments

5 participants

@D1plo1d

Whenever I attempt to run pod install pod fails to create a Pods directory or is looking in the wrong place for it (not sure which) and errors out.

If I create the Pods directory pod install succeeds but then errors out in all other sorts of ways when I go to compile xcode (so thats almost certainly a separate ticket once this has been resolved).

My Stack

  • OSX 10.7.3
  • rbenv
  • ruby 1.9.3p125 (2012-02-16 revision 34643) [x86_64-darwin11.3.0]
  • gems 1.8.11
  • xcode 4.3
  • cocoapods gem 0.5.1 (via gem install cocoapods)

Heres what my console looks like

$ pod install cocoapodTest.xcodeproj --verbose
Updating spec repo `master'
/usr/bin/git pull
Already up-to-date.
Installing dependencies of: /Users/rob/Documents/cocoapodTest/Podfile
Generating support files
* Generating xcconfig file at `/Users/rob/Documents/cocoapodTest/Pods/Pods.xcconfig'
Oh no, an error occurred. Please run with `--verbose' and report on https://github.com/CocoaPods/CocoaPods/issues.

No such file or directory - /Users/rob/Documents/cocoapodTest/Pods/Pods.xcconfig
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/xcodeproj-0.1.0/lib/xcodeproj/config.rb:28:in `initialize'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/xcodeproj-0.1.0/lib/xcodeproj/config.rb:28:in `open'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/xcodeproj-0.1.0/lib/xcodeproj/config.rb:28:in `open'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/xcodeproj-0.1.0/lib/xcodeproj/config.rb:28:in `save_as'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/installer/target_installer.rb:117:in `create_files_in'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:85:in `block in install!'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:83:in `each'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:83:in `install!'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/command/install.rb:44:in `run'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/lib/cocoapods/command.rb:53:in `run'
/Users/rob/.rbenv/versions/1.9.3-p125/lib/ruby/gems/1.9.1/gems/cocoapods-0.5.1/bin/pod:11:in `<top (required)>'
/Users/rob/.rbenv/versions/1.9.3-p125/bin/pod:19:in `load'
/Users/rob/.rbenv/versions/1.9.3-p125/bin/pod:19:in `<main>'
@alloy
Owner

Uhoh. Can you show the contents of your Podfile?

@D1plo1d

sure!

$ cat Podfile
platform :ios
dependency 'RestKit'
@alloy
Owner

Argh, that’s basically the same issue as #160. Can you close the issue if that’s indeed the case?

I like how you included your stack btw, I keep forgetting to update the message that asks you to report the problem with such info.

@D1plo1d

Thank you for the link, I didn't come across that one in my googling. That appears to fix the problem however explicit documentation to indicate that you can't install parent specs would be very helpful to future legions of cocoapod nubs like me :)

Edit: np on the stack infos. I know how much of a pain vague bug reports can be.

@D1plo1d D1plo1d closed this
@alloy
Owner

An example of the output:

Stack

  • Host version: Mac OS X 10.7.2 (11C74)
  • Xcode version: 4.2 (4D199)
  • Ruby version: ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0]
  • Ruby lib dir: /Users/eloy/.rbenv/versions/1.9.3-p0/lib
  • RubyGems version: 1.8.11
  • CocoaPods version: 0.5.1
  • Specification repositories:

Podfile

platform :

dependency 'BlocksKit'

Error

/Users/eloy/tmp/BlocksKit/Podfile:1: syntax error, unexpected ':', expecting $end
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:33:in `eval'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:33:in `block in from_file'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:44:in `instance_eval'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:44:in `initialize'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:32:in `new'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/podfile.rb:32:in `from_file'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/config.rb:53:in `rootspec'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/command/install.rb:34:in `run'
  /Users/eloy/code/cocoapods/CocoaPods/lib/cocoapods/command.rb:54:in `run'
  /Users/eloy/code/cocoapods/CocoaPods/bin/pod:13:in `<main>'
@fabiopelosin fabiopelosin referenced this issue from a commit
@fabiopelosin fabiopelosin Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Fix .kick script for Kicker 2.5.0
  Print a template for a new ticket when an error occurs. See #163.
dc03174
@jk
jk commented

Sorry to use this issue: But is this issue fixed? Today I upgraded to the recent version of CocoaPods with gem install cococapods to obtain 0.5.1 (I came from 0.3.x) and ran into the exact same issue as @D1plo1d for one of my new project - so that's 15 days for a non-working CocoaPods version out there?

What's the workaround for this issue (since I'm not very familiar with the gem things…)? Can I easily build my own pods binary from the source, to get it working again?

@alloy
Owner

@jk Afaik, @D1plo1d has been able to use the RestKit specs as described in #160. CocoaPods is not fundamentally broken here, but we do need to enhance the UX.

What's the workaround for this issue (since I'm not very familiar with the gem things…)? Can I easily build my own pods binary from the source, to get it working again?

Yeah you can, but first let’s see if we can troubleshoot your issue. Can you paste the contents of your Podfile?

@jk
jk commented

Sure, it's just:

platform :ios
dependency 'RestKit', '~> 0.9.3'
@alloy
Owner

Ok, so this is indeed that same issue. From #160:

Indeed, the error reporting on this should be improved for the next release.

So the problem is that you can’t install the spec that wraps many ‘sub specs’ (which is what makes it DOWNLOAD_ONLY). So to install, for instance, RestKit with ObjectMapping and JSONKit use:

dependency 'RestKit/ObjectMapping/JSONKit'

I.e. you currently can not depend on simply ‘RestKit’, but you have to instead depend on the specific modules (sub specs) that you want to use.

@jk
jk commented

Ah so it's a issue with RestKit itself. I thought that it's related to some kind of permission problem, since --verbose states that it's unable to create some files.

So if someone after me finds this issue:

platform :ios
dependency 'RestKit/ObjectMapping/JSONKit', '~> 0.9.3'

Does the trick for me. Thanks @alloy

@dmishe

I just had the same issue with RestKit,
RestKit/ObjectMapping/JSONKit does not solve it

@fabiopelosin

@dmishe Can report the version of cocoapods? If you are using the 0.6.0.rc2 the following should work:

platform :ios
dependency 'RestKit'

[Edit: Removed version as I'm not sure that the older versions of RestKit have been updated for CP 0.6.

@dmishe
@fabiopelosin
$ [sudo] gem install cocoapods --pre
@fabiopelosin fabiopelosin referenced this issue from a commit
@fabiopelosin fabiopelosin Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Fix .kick script for Kicker 2.5.0
  Print a template for a new ticket when an error occurs. See #163.
0a60797
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.