Development pod framework dependency missing #1858

Closed
vitaminwater opened this Issue Mar 5, 2014 · 3 comments

Comments

Projects
None yet
2 participants

(I'm quite new to cocoapods so this could be a misunderstanding related issue)

When adding a development pod, with:

pod 'CCSocialManager', :path => '../CCSocialManager'

Which has 2 dependencies:

google-plus-ios-sdk and Facebook-iOS-SDK

The dependencies are added to the project, but the CCSocialManager pods source files can't find the google plus header files. It works for Facebook though (which is source files, not Framework).

The fix I got to do was to add

"$(PODS_ROOT)/google-plus-ios-sdk/google-plus-ios-sdk-1.5.0"

to the "Framework Search Path" of the CCSocialManager target in the Pods project.

Contributor

kylef commented Mar 11, 2014

Is this a duplicate of #1524?

No, the framework is there, and everything is accessible from the main project.

I'll try to make myself clearer with a screenshot:
error

On the screenshot the Development pod at 1 can't see the googleplus.framework headers at 2.

Contributor

kylef commented Mar 17, 2014

@vitaminwater this was an issue with the google-plus-ios-sdk pod spec which has now been fixed in the latest version.

CocoaPods/Core#57 would change this in the future.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment