Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

LoadError - no such file to load #1863

Closed
fuxiaohui opened this Issue Mar 7, 2014 · 6 comments

Comments

Projects
None yet
6 participants

Stack

   CocoaPods : 0.29.0
        Ruby : ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin13.0]
    RubyGems : 2.2.1
        Host : Mac OS X 10.9.2 (13C64)
       Xcode : 5.0.2 (5A3005)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 0f36f3006e2fdb730ce470a5a3415d35abfdddd3

Error

LoadError - no such file to load -- xcodeproj/prebuilt/universal-darwin13.0-1.8.7/xcodeproj_ext
/Library/Ruby/Site/1.8/rubygems/core_ext/kernel_require.rb:55:in `gem_original_require'
/Library/Ruby/Site/1.8/rubygems/core_ext/kernel_require.rb:55:in `require'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.14.1/lib/xcodeproj/ext.rb:6
/Library/Ruby/Site/1.8/rubygems/core_ext/kernel_require.rb:55:in `gem_original_require'
/Library/Ruby/Site/1.8/rubygems/core_ext/kernel_require.rb:55:in `require'
/Library/Ruby/Gems/1.8/gems/xcodeproj-0.14.1/lib/xcodeproj/project.rb:4
/Library/Ruby/Gems/1.8/gems/cocoapods-0.29.0/lib/cocoapods/command/init.rb:39:in `validate!'
/Library/Ruby/Gems/1.8/gems/claide-0.4.0/lib/claide/command.rb:212:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.29.0/lib/cocoapods/command.rb:51:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.29.0/bin/pod:24
/usr/bin/pod:23:in `load'
/usr/bin/pod:23
Contributor

kylef commented Mar 11, 2014

OS X 10.9.2 has ruby version 2.0.0 as default and these errors show Ruby 1.8.7.

Can you run ruby -v, assuming that is 2.0.0, it should be fixable by installing the gem again (which will create the new bin stub to point to the correct 2.0.0 place).

3Q,I run $ sudo gem install cocoa pods,this is fine

'sudo gem install cocoapods' works for me.

Owner

alloy commented Mar 13, 2014

Probably because it installed a new pod binstub in /usr/bin where previously there was a binstub installed in OS X 10.8 with Ruby 1.8.7.

@alloy alloy closed this Mar 13, 2014

Didn't work for me..

Gigha commented Jun 14, 2015

Removing the pod binary (in /usr/bin/pod) and uninstalling cocoapods (sudo gem uninstall cocoapods) and reinstalling cocoapods (sudo gem install cocoapods) worked for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment