Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Podfile DSL requires a default project, but doesn't say that #1923

Closed
dblock opened this Issue · 2 comments

5 participants

@dblock

Consider this Podfile:

workspace "ARASCIISwizzle"

pod "ARASCIISwizzle", :path => "ARASCIISwizzle.podspec"

xcodeproj "Demo.xcodeproj"

target "Tests" do
  pod 'Specta', '~> 0.2.1'
  pod 'Expecta', '~> 0.2.3'
  pod 'FBSnapshotTestCase', :head
  xcodeproj "Tests.xcodeproj"
end

target "Demo" do
  pod "FLKAutoLayout", "~> 0.1.1"
  xcodeproj "Demo.xcodeproj"
end

The first xcodeproj "Demo.xcodeproj" is required and I don't know what it does. Does it mean "default project"? This should be an explicit thing in the DSL and if it is the default, I should be able to omit it and just use the first one below.

@mokagio

+1

@fabiopelosin fabiopelosin self-assigned this
@kylef
Owner

This will be fixed by #840.

workspace "MyWorkspace"
  project "MyProject" do
    target "Tests" do
      configuration "Development" do
        pod 'Specta', '~> 0.2.1'
      end
     end
   end
end
@kylef kylef closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.