The `master` repo requires CocoaPods 0.32.0 - #2049

Closed
dblock opened this Issue Apr 15, 2014 · 4 comments

Projects

None yet

2 participants

@dblock

I have a Podfile, do a gem install cocoapods and get 0.32. The error message is:

[!] The version of CocoaPods used to generate the lockfile is higher that the one of the current executable. Incompatibility issues might arise.
[!] The `master` repo requires CocoaPods 0.32.0 - 

That's not helpful. I have CocoaPods 0.32. I suppose it meant to say that something in my Podfile is wrong, but what is it? :)

Note that there's nothing in CHANGELOG that talks about backwards incompatibility.

How do I resolve this?

@fabiopelosin
CocoaPods member

can you paste the output of:

$ pod --version
@dblock

Alright, problem between the computer and the chair.

$ pod --version
0.29.0

Looks like I always get 2, a default one and a bundler one, need to always use one.

I think this can be closed. Maybe you want to change the error into listing the current version.

@dblock dblock closed this Apr 15, 2014
@fabiopelosin
CocoaPods member

Yeah bundler and Ruby in general can lead to some gotchas with the version of the gems.

Reopening as the original error presented by CocoaPods was not clear enough as it should list the version to remove any doubt.

@fabiopelosin fabiopelosin reopened this Apr 15, 2014
@dblock

Thanks for your prompt help @irrationalfab .

@kylef kylef closed this in #2051 May 1, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment