Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

`Pod::Executable` error message is missing the command #2102

Closed
kylef opened this Issue May 2, 2014 · 2 comments

Comments

Projects
None yet
2 participants
Contributor

kylef commented May 2, 2014

The following output I got from CocoaPod's is missing the git command. Just printing the arguments.

Analyzing dependencies
[!] Pod::Executable pull --no-rebase --no-commit

You have not concluded your merge (MERGE_HEAD exists).

Please, commit your changes before you can merge.

So, i'd expect the following:

-[!] Pod::Executable pull --no-rebase --no-commit
+[!] Pod::Executable git pull --no-rebase --no-commit
Owner

neonichu commented May 3, 2014

Acually, I think the Pod::Executable in there is just the typo causing this issue. I think it should not be in that message.

@neonichu neonichu added a commit that referenced this issue May 3, 2014

@neonichu neonichu Spec for #2102 a9e41ac

@neonichu neonichu added a commit that referenced this issue May 3, 2014

@neonichu neonichu CHANGELOG entry for #2102 2e3bf3d
Owner

neonichu commented May 3, 2014

Fixed in a16e226

@neonichu neonichu closed this May 3, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment