Pod not updated when I specify new version in Podfile #297

Closed
yas375 opened this Issue Jun 4, 2012 · 3 comments

Projects

None yet

2 participants

@yas375
Contributor
yas375 commented Jun 4, 2012

Screencast: http://screencast.com/t/NrNtFaGwZ

CocoaPods: 0.6.0.rc1

Steps to reproduce:

  1. Create xcode project
  2. Create Podfile with next content:
platform :ios

dependency 'MagicalRecord', '2.0'
  1. run pod install
  2. change Podfile to:
platform :ios

dependency 'MagicalRecord', '2.0.3'
  1. run pod install

Bug:

No changes in MagicalRecord files in Pods directory. It's still 2.0 version here.

Expected:

Magical Record will be updated to the 2.0.3 version.

The way to get round of the bug

rm -rf Pods
pod install
@fabiopelosin
Member

This logic hasn't been implemented yet :-) (see #191). Currently CocoaPods just installs a pod only if the correspondent directory doesn't exists.

Btw, you can just do:

$ rm -rf Pods/MagicalRecord
$ pod install
@yas375
Contributor
yas375 commented Jun 4, 2012

Oh, sorry for duplicate! It's my fault(

@fabiopelosin
Member

Oh, sorry for duplicate! It's my fault(

haha... don't worry about that :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment