New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CocoaPods is unable to read YAML files when Psych 2.0.13 is installed #3539

Closed
kylef opened this Issue May 8, 2015 · 16 comments

Comments

Projects
None yet
7 participants
@kylef
Copy link
Contributor

kylef commented May 8, 2015

See #2908 and #3490.

We should investigate why it's broken in Psych and potentially fix the problem. If that's not easily achievable we should perhaps pin to Psych 2.0.0 in our gem spec.

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented May 8, 2015

@kylef if we pin psych, that will force people to compile a c extension.

@kylef

This comment has been minimized.

Copy link
Contributor

kylef commented May 8, 2015

@segiddins even if we pin to the version that's included on the system by default?

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented May 8, 2015

Different ruby versions come bundled with different versions of psych

-Samuel E. Giddins

On May 8, 2015, at 7:43 AM, Kyle Fuller notifications@github.com wrote:

@segiddins even if we pin to the version that's included on the system by default?


Reply to this email directly or view it on GitHub.

@neonichu

This comment has been minimized.

Copy link
Member

neonichu commented May 8, 2015

Current system rubies we support are: 2.0.0-p481, 2.0.0-p451 and 2.0.0-p247, right? Maybe those happen to ship with the same version of Psych?

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented May 8, 2015

No clue, I use 2.3.0-dev day to day.

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented May 31, 2015

I can't reproduce this with Psych 2.0.13, an in multiple ruby versions

@cbowns

This comment has been minimized.

Copy link

cbowns commented Jun 1, 2015

A big 👍, I just hit this error as well. I think another gem I installed today (via rbenv) brought in psych.

[!] There was an error reading '/Users/cbowns/.cocoapods/repos/master/CocoaPods-version.yml'

cbowns at Atlas in ~ ☃
% ○ gem uninstall psych              
Successfully uninstalled psych-2.0.13

cbowns at Atlas in ~ ☆
% ○ pod setup                        
Setting up CocoaPods master repo
Already up-to-date.
Setup completed

(My env: rbenv with some gems from local ruby projects, running:

% ± ruby --version                                                                                                                                                                    2015-06-01 [16:28:13]
ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-darwin14]
@cbowns

This comment has been minimized.

Copy link

cbowns commented Jun 1, 2015

Via #2908 (comment):

"Also reported at rubocop-hq/rubocop#1510 -- someone said it might be a RubyGems bug?"

@steakknife

This comment has been minimized.

Copy link

steakknife commented Jul 27, 2015

  • Ruby 2.2.2
  • gem (RubyGems) 2.4.8
  • psych 2.0.13 (and 2.0.8 which cannot be uninstalled because it's a "system" gem)
  • cocoapods 0.38.2

The trick seems to be gem update --system (to update RubyGems to a recent version itself which patches some Psych-related things):

So start clean:

rm -rf ~/Library/Caches/CocoaPods ~/.cocoapods; \
gem update --system && \
gem update && \
gem cleanup && \
pod setup

Before

Setting up CocoaPods master repo
Already up-to-date.
[!] There was an error reading '/Users/xxxxx/.cocoapods/repos/master/CocoaPods-version.yml'.
Please consult http://blog.cocoapods.org/Repairing-Our-Broken-Specs-Repository/ for more information.

After

Setting up CocoaPods master repo
Setup completed
@wkoszek

This comment has been minimized.

Copy link

wkoszek commented Nov 23, 2015

Got the same error today:

Setting up CocoaPods master repo
Already up-to-date.
[!] There was an error reading '/Users/xxxxx/.cocoapods/repos/master/CocoaPods-version.yml'.
Please consult http://blog.cocoapods.org/Repairing-Our-Broken-Specs-Repository/ for more information.

I had to use @steakknife fix to un-break my system.

This website:

http://blog.cocoapods.org/Repairing-Our-Broken-Specs-Repository/

should be extended to mention this bug case, since the original fix suggested there didn't work for me.

@3lvis

This comment has been minimized.

Copy link

3lvis commented Dec 9, 2015

Got this error today after updating my gems. I agree with @wkoszek, would be nice to have this bug mentioned on http://blog.cocoapods.org/Repairing-Our-Broken-Specs-Repository/

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented Dec 9, 2015

A PR updating the guides page would be much appreciated!

@3lvis

This comment has been minimized.

Copy link

3lvis commented Dec 9, 2015

@segiddins Could you please help me find where to do the contribution? GitHub search is not helping 😞

@segiddins

This comment has been minimized.

Copy link
Member

segiddins commented Dec 9, 2015

Arg it's the blog, sorry. GitHub.com/CocoaPods/blog.cocoapods.org

@3lvis

This comment has been minimized.

Copy link

3lvis commented Dec 9, 2015

Added a small paragraph regarding this issue, might not be the best wording but I'm open to improve it until you guys think it's good enough for people that have this same problem.

CocoaPods/blog.cocoapods.org#110

@neonichu

This comment has been minimized.

Copy link
Member

neonichu commented May 2, 2016

Let's close this since this problem is mentioned in guides now.

@neonichu neonichu closed this May 2, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment