TestFlightSDK won't install #412

Closed
thepatrick opened this Issue Jul 18, 2012 · 3 comments

Projects

None yet

3 participants

@thepatrick

Worse than that, it's already installed, but now I can't install anything else without removing it.

Grace:My App patrick$ pod install --verbose
Updating spec repo `master'
/usr/bin/git pull
Already up-to-date.
Installing dependencies of: /Users/patrick/SourceCache/git/My App/Podfile
Oh no, an error occurred. Please run with `--verbose' and report on https://github.com/CocoaPods/CocoaPods/issues.

undefined method `preserve_paths=' for #<Pod::Specification for TestFlightSDK (1.0)>
/Users/patrick/.cocoapods/master/TestFlightSDK/1.0/TestFlightSDK.podspec:12:in `_eval_podspec'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/specification.rb:25:in `initialize'
/Users/patrick/.cocoapods/master/TestFlightSDK/1.0/TestFlightSDK.podspec:1:in `new'
/Users/patrick/.cocoapods/master/TestFlightSDK/1.0/TestFlightSDK.podspec:1:in `_eval_podspec'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/specification.rb:16:in `eval'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/specification.rb:5:in `_eval_podspec'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/specification.rb:16:in `from_file'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/specification/set.rb:59:in `specification'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/resolver.rb:21:in `find_dependency_sets'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/resolver.rb:14:in `each'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/resolver.rb:14:in `find_dependency_sets'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/resolver.rb:9:in `resolve'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:7:in `dependent_specifications'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:11:in `build_specifications'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:57:in `install_dependencies!'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/installer.rb:75:in `install!'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/command/install.rb:44:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/lib/cocoapods/command.rb:53:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.5.1/bin/pod:11
/usr/bin/pod:19:in `load'
/usr/bin/pod:19
@dlvenable
Contributor

You appear to be running CocoaPods 0.5.1. The TestFlightSDK pod spec requires at least version 0.6 (if not higher). I am able to install it from CocoaPods 0.9.2, which is the latest version.

@thepatrick

Does 0.9.2 handle this error case better?

(Also damn ruby and gems putting things in weird places resulting in even though I installed 0.9.2 it still wanting to use 0.5.1)

@thepatrick thepatrick closed this Jul 18, 2012
@fabiopelosin
Member

Does 0.9.2 handle this error case better?

@thepatrick Since 6.0 CocoaPods checks if the specs repo is compatible and with the current installed version of CocoaPods and notifies the user if it isn't.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment