Skip to content


Cocoapods and Octokit 1.11.0 #490

Zyphrax opened this Issue · 0 comments

2 participants


After upgrading octokit the pod setup didn't work anymore (caused by gem update).
Does cocoapods really need version 1.7.0? I assume 1.11.0 would work as well?

$ pod setup
/Library/Ruby/Site/1.8/rubygems/dependency.rb:247:in `to_specs': Could not find octokit (~> 1.7.0)
amongst [activesupport-3.2.8, addressable-2.3.2, cocoapods-0.13.0, colored-1.2,
escape-0.0.4, faraday-0.8.4, faraday_middleware-0.8.8, hashie-1.2.0, i18n-0.6.0,
json-1.7.5, multi_json-1.3.6, multipart-post-1.1.5, octokit-1.11.0, open4-1.3.0, rake-,
rubygems-update-1.8.24, xcodeproj-0.3.2] (Gem::LoadError)
    from /Library/Ruby/Site/1.8/rubygems/specification.rb:777:in `activate_dependencies'
    from /Library/Ruby/Site/1.8/rubygems/specification.rb:766:in `each'
    from /Library/Ruby/Site/1.8/rubygems/specification.rb:766:in `activate_dependencies'
    from /Library/Ruby/Site/1.8/rubygems/specification.rb:750:in `activate'
    from /Library/Ruby/Site/1.8/rubygems.rb:1232:in `gem'
    from /usr/bin/pod:22
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.