I'm having installation problem after running pod setup #570

Closed
ozba opened this Issue Oct 3, 2012 · 2 comments

2 participants

@ozba

I ran:
"sudo gem install cocoapods"

everything seems to be installed just fine.

Than I ran:
"pod setup"

and I got:
/Library/Ruby/Gems/1.8/gems/cocoapods-0.15.0/lib/cocoapods.rb:10: undefined method red' for #<String:0x10cd498f8> (NoMethodError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in require'
from /Library/Ruby/Gems/1.8/gems/cocoapods-0.15.0/bin/pod:14
from /usr/bin/pod:19:in
load'
from /usr/bin/pod:19

Any suggestions?

@ozba

resolved, had to do :
sudo gem update --system

@fabiopelosin
CocoaPods member

You needed to update, but we are crashing while printing the message that was supposed to inform you :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment