upper is smaller than lower in repeat range: /(.{1,0})( +|$)\n?|(.{0})/ #582

Closed
jk opened this Issue Oct 6, 2012 · 2 comments

Comments

Projects
None yet
3 participants

jk commented Oct 6, 2012

Report

  • What did you do?
    Building an iOS project with Jenkins. The Jenkins CocoaPods specific shell call looks like the following:
# Install CocoaPods dependencies
rvm current
rm -Rf Pods Podfile.lock
pod --no-color install
  • What did you expect to happen?
    Since it runs as the same user when firing the same command on the command line, I expect that this runs too. I think I'm missing something here. But the 0.11 version worked fine for me.
  • What happened instead?
    Some wired error messages. Looks below.

Stack

   CocoaPods : 0.15.1
        Ruby : ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin12.2.0]
    RubyGems : 1.8.24
        Host : Mac OS X 10.8.2 (12C60)
       Xcode : 4.5.1 (4G1004)
Ruby lib dir : ~/.rvm/rubies/ruby-1.9.3-p194/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 7de0b37be558e1152a2cef5331e454b15d7c8572

Podfile

          #pod 'HockeySDK'
platform :ios, '5.1'
pod 'AFNetworking'
# pod 'DCIntrospect'
pod 'DDPageControl', :podspec => 'https://gist.github.com/raw/3175904/6902d062cefef43f1d3f976a582ebc9df6d979d9/DDPageControl.podspec'
pod 'FlurrySDK'
pod 'FrameAccessor'
pod 'GMGridView'
pod 'lzmaSDK', :podspec => 'https://gist.github.com/raw/3075937/0daad79055d50a93dc2dd35b17c15586c22a2c64/lzmaSDK.podspec' # to extract 7z
pod 'NSDate+Helper'
pod 'NSLogger-CocoaLumberjack-connector', :podspec => 'https://raw.github.com/gist/2966540/0edc7676f2f5b4b89f43512c603c529401239dbc/NSLogger-CocoaLumberjack-connector.podspec'
pod 'PSStoreButton', :podspec => 'https://raw.github.com/gist/3775724/c01483f5fdc1b66a1cec3dfc2a1c3a5afb56c08c/PSStoreButton.podspec'
pod 'SFHFKeychainUtils', '0.0.1'
pod 'SimStoreKit', :podspec => 'https://raw.github.com/gist/3786468/88228c85c743275949696816a8730dd8e62e4fdb/SimStoreKit.podspec'
pod 'SVProgressHUD', '0.6'
pod 'SVWebViewController'
pod 'TestFlightSDK'

Error

upper is smaller than lower in repeat range: /(.{1,0})( +|$)\n?|(.{0})/
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/user_interface.rb:210:in `wrap_string'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/user_interface.rb:89:in `info'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/dependency.rb:220:in `copy_external_source_into_sandbox'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/dependency.rb:168:in `specification_from_external'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/dependency.rb:158:in `specification_from_sandbox'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:164:in `find_cached_set'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:192:in `block (2 levels) in find_dependency_specs'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/user_interface.rb:77:in `message'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:191:in `block in find_dependency_specs'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:186:in `each'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:186:in `find_dependency_specs'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:92:in `block (2 levels) in resolve'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/user_interface.rb:37:in `section'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:90:in `block in resolve'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:89:in `each'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/resolver.rb:89:in `resolve'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/installer.rb:198:in `specs_by_target'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/installer.rb:111:in `block in install!'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/user_interface.rb:37:in `section'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/installer.rb:110:in `install!'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/command/install.rb:46:in `run_install_with_update'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/command/install.rb:51:in `run'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/lib/cocoapods/command.rb:75:in `run'
~/.rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.15.1/bin/pod:16:in `<top (required)>'
~/.rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `load'
~/.rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `<main>'
~/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
~/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

fabiopelosin was assigned Oct 8, 2012

claybridges closed this Oct 8, 2012

My bad, reopened. This is likely related to the issue we were having in #575.

claybridges reopened this Oct 8, 2012

Owner

fabiopelosin commented Oct 10, 2012

Closed by 733d6aa.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment