Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pod trunk push: "xcodebuild: error: 'App.xcworkspace' does not exist." #5843

Closed
malcommac opened this Issue Sep 11, 2016 · 14 comments

Comments

Projects
None yet
8 participants
@malcommac
Copy link

malcommac commented Sep 11, 2016

Report

I've tried to make a pod trunk push of my cocoapod lib using XCode 8 (used sudo xcode-select -s /Applications/Xcode.app where Xcode.app is v. 8) and process if failed with this error:

What did you do?

pod trunk push

What did you expect to happen?

New version should be pushed.

What happened instead?

Failed to push with error:

[!] Found podspec `xxx.podspec`
Updating spec repo `master`

CocoaPods 1.1.0.rc.1 is available.
To update use: `sudo gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.1.0.rc.1

Validating podspec
 -> xxx (1.0.6)
    - ERROR | [iOS] xcodebuild: Returned an unsuccessful exit code. You can use `--verbose` for more information.
    - NOTE  | [iOS] xcodebuild:  xcodebuild: error: 'App.xcworkspace' does not exist.

CocoaPods Environment

Stack

   CocoaPods : 1.0.1
        Ruby : ruby 2.2.4p230 (2015-12-16 revision 53155) [x86_64-darwin15]
    RubyGems : 2.4.8
        Host : Mac OS X 10.11.6 (15G1004)
       Xcode : 8.0 (8A218a)
         Git : git version 2.8.4 (Apple Git-73)
Ruby lib dir : /Users/xxx/.rvm/rubies/ruby-2.2.4/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 2e52a5c8dc155a94947515ea5728ca3b990e9b82

Installation Source

Executable Path: /Users/xxx/.rvm/gems/ruby-2.2.4/bin/pod

Plugins

cocoapods-deintegrate : 1.0.1
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.0.0
cocoapods-trunk       : 1.0.0
cocoapods-try         : 1.1.0
@jonasman

This comment has been minimized.

Copy link

jonasman commented Sep 11, 2016

that is fixed on CocoaPods 1.1.0.rc.1

@benasher44

This comment has been minimized.

Copy link
Member

benasher44 commented Sep 11, 2016

Yep!

@benasher44 benasher44 closed this Sep 11, 2016

@malcommac

This comment has been minimized.

Copy link
Author

malcommac commented Sep 11, 2016

Cool, I've tried to update using

sudo gem install cocoapods --pre

but I still get

Stack

   CocoaPods : 1.0.1
        Ruby : ruby 2.2.4p230 (2015-12-16 revision 53155) [x86_64-darwin15]
    RubyGems : 2.4.8
        Host : Mac OS X 10.11.6 (15G1004)
       Xcode : 8.0 (8A218a)
         Git : git version 2.8.4 (Apple Git-73)
Ruby lib dir : /Users/danielemargutti/.rvm/rubies/ruby-2.2.4/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 2e52a5c8dc155a94947515ea5728ca3b990e9b82

Installation Source

Executable Path: /Users/danielemargutti/.rvm/gems/ruby-2.2.4/bin/pod

Plugins

cocoapods-deintegrate : 1.0.1
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.0.0
cocoapods-trunk       : 1.0.0
cocoapods-try         : 1.1.0

What's wrong?

@malcommac

This comment has been minimized.

Copy link
Author

malcommac commented Sep 11, 2016

Okay seems I've installed three different versions of cocoapods.
Removed using sudo gem uninstall cocoapods and installed again viasudo gem install cocoapods --pre

@CNKCQ

This comment has been minimized.

Copy link

CNKCQ commented Sep 16, 2016

the same error

@malcommac

This comment has been minimized.

Copy link
Author

malcommac commented Sep 16, 2016

uninstall all cocoapods version reinstall and reset your pods. It should work fine.

@fulldecent

This comment has been minimized.

Copy link
Contributor

fulldecent commented Sep 16, 2016

I updated to 1.1.0.rc.2 not it give me a bunch of errors because it is not recognizing this is a Swift 3 project.

@hectormatos2011

This comment has been minimized.

Copy link

hectormatos2011 commented Sep 18, 2016

I'm getting this issue on non rc version of 1.0.1. When updating to 1.1.0.rc.2, I'm also getting errors from xcodebuild that look as though it doesn't know what Swift 3 is even though Xcode 8 is the only environment I have on my machine.

@hectormatos2011

This comment has been minimized.

Copy link

hectormatos2011 commented Sep 18, 2016

@neonichu and @segiddins, don't know if you guys are working on this or not, but PrediKit on the master branch has this issue when doing a pod trunk push. Updating to 1.1.0.rc.2 fixes the issue but won't compile the project during the validation step after my conversion to Swift 3.

@hectormatos2011

This comment has been minimized.

Copy link

hectormatos2011 commented Sep 18, 2016

Figured it out. @fulldecent I know you're having this problem too. In case you haven't figured it out yet, go to where your podspec is, and execute this command in terminal:

echo 3.0 > .swift-version

Try a pod trunk push again and see it that works for you

@hectormatos2011

This comment has been minimized.

Copy link

hectormatos2011 commented Sep 18, 2016

@neonichu && @segiddins, you can ignore me now.

@neonichu

This comment has been minimized.

Copy link
Member

neonichu commented Sep 18, 2016

Ya tu sabes

@guidev

This comment has been minimized.

Copy link

guidev commented Sep 19, 2016

same here

@fulldecent

This comment has been minimized.

Copy link
Contributor

fulldecent commented Sep 19, 2016

@hectormatos2011 Thank you, this worked. I added that step to a full recipe for people making Swift 3 modules at:

https://github.com/fulldecent/swift3-module-template

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.