Make Swift 3 the default when linting pods #6041

Closed
benasher44 opened this Issue Oct 15, 2016 · 0 comments

Projects

None yet

2 participants

@benasher44
Member

When we started working on CocoaPods 1.1.0, Swift 2.3 as the default makes sense. This no longer feels like the right choice for a number of reasons:

  • Swift 2.3 is considered "legacy" in Xcode 8, and pods/libraries are quickly migrating to Swift 3.
  • A future release of Xcode will not support Swift 2.3
@benasher44 benasher44 added this to the 1.1.0 milestone Oct 15, 2016
@DanToml DanToml was assigned by benasher44 Oct 15, 2016
@DanToml DanToml closed this in #6042 Oct 16, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment