invalid byte sequence in US-ASCII #639

Closed
shmidt opened this Issue Nov 8, 2012 · 6 comments

Projects

None yet

5 participants

@shmidt
shmidt commented Nov 8, 2012

Report

  • What did you do?

Tried to install PrettyKit 0.2.0

  • What did you expect to happen?

Installation

  • What happened instead?

This report

Stack

   CocoaPods : 0.14.0
        Ruby : ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.0]
    RubyGems : 1.8.24
        Host : Mac OS X 10.8.2 (12C60)
       Xcode : 4.5.2 (4G2008a)
Ruby lib dir : /usr/local/rvm/rubies/ruby-1.9.3-p194/lib
Repositories : master - git://github.com/CocoaPods/Specs.git @ ba9282968277e5a2a2add44402b616308937aecd

Podfile

          platform :ios
pod 'PrettyKit', '~>0.2.0'

Error

invalid byte sequence in US-ASCII
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:515:in `glob'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:515:in `glob'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:515:in `block in expanded_paths'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:509:in `map'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:509:in `expanded_paths'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/local_pod.rb:303:in `readme_file'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/generator/documentation.rb:50:in `index_file'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/generator/documentation.rb:70:in `appledoc_options'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/generator/documentation.rb:81:in `generate'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/installer.rb:93:in `generate_docs'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/installer.rb:65:in `block in install_dependencies!'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/installer.rb:50:in `each'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/installer.rb:50:in `install_dependencies!'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/installer.rb:120:in `install!'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/command/install.rb:46:in `run_install_with_update'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/command/install.rb:52:in `run'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/lib/cocoapods/command.rb:76:in `run'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.14.0/bin/pod:12:in `<top (required)>'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `load'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `<main>'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'
@yury
yury commented Dec 18, 2012

add export LC_ALL="en_US.UTF-8" to your ~/.zshrc or ~/.bashrc

@shmidt
shmidt commented Dec 18, 2012

Thanks for the answer,
currently I can't check it because I reinstalled system and using bash.

@shmidt shmidt closed this Dec 18, 2012
@Whirlwind

I tried it , but it not works!
I use iTerm2, ruby 1.9.3p392.

@AliSoftware AliSoftware changed the title from https://github.com/CocoaPods/CocoaPods/issues/search?q=invalid+byte+sequence+in+US-ASCII to invalid byte sequence in US-ASCII May 29, 2014
@frnkhng
frnkhng commented Jul 15, 2014

thanks the answer!

@jollychang

@yury I got the issue too, i have set LC_ALL to "en_US.UTF-8" and podfile is utf-8 encoding

[jollychang@WilliamMBP Frodo-iOS]$ head -n 10 ~/.bashrc
set -o emacs
export LANG=en_US.UTF-8
export LC_COLLATE=en_US.UTF-8
export LC_CTYPE=en_US.UTF-8
export LC_MESSAGES=en_US.UTF-8
export LC_MONETARY=en_US.UTF-8
export LC_NUMERIC=en_US.UTF-8
export LC_TIME=en_US.UTF-8
export LC_ALL=en_US.UTF-8
PAGER='less -X -M'
[jollychang@WilliamMBP Frodo-iOS]$ locale
LANG="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
[jollychang@WilliamMBP Frodo-iOS]$ pod install
Analyzing dependencies
Pre-downloading: `MQTTKit` from `https://github.com/jmesnil/MQTTKit.git`, commit `5ee5cf3819`
Downloading dependencies
Installing AFNetworking (1.3.3)
Installing ActionSheetPicker (0.0.2)
Installing AmonsulIOS (1.5.2)
Installing DOUFoundation (0.2.1)
Installing DOURegisterKit (1.2.1)
Installing DOUSNSSharing (2.3.6)
Installing DOUUserManager (1.0.1)
Installing DoubanObjCClient (1.3.1)
Installing DoubanObjCFileManager (1.0.6)
Installing FXBlurView (1.6.2)
Installing JSQSystemSoundPlayer (1.5.2)
Installing MQTTKit (0.1.0)
Installing PSTCollectionView (1.2.1)
Installing SDWebImage (3.5.2)
Installing SORelativeDateTransformer (1.1.10)
Installing SVProgressHUD (1.0)
Installing UIImage+BlurredFrame (0.0.4)
Installing Weibo (2.4.2)
Installing YAUIKit (1.1.6)

――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

### Report

* What did you do?

* What did you expect to happen?

* What happened instead?


### Stack

CocoaPods : 0.33.1
Ruby : ruby 1.9.3p374 (2013-01-15 revision 38858) [x86_64-darwin12.2.0]
RubyGems : 2.2.1
Host : Mac OS X 10.9.4 (13E28)
Xcode : 5.0 (5A1412)
Ruby lib dir : /usr/local/Cellar/ruby/1.9.3-p374/lib
Repositories : douban - http://code.dapps.douban.com/CocoaPodsSpecs.git @ c228aba175cc1acb127bf395a9a143597a5f41b5
master - http://code.dapps.douban.com/mirror/Specs.git @ f3853e624817e37f30108cd91de947d0e87fe7b1


### Podfile

```ruby
platform :ios, '7.0'

pod 'AmonsulIOS',                '~> 1.5.1'
pod 'DOUUserManager',            '~> 1.0.0'
pod 'DoubanObjCClient',          '~> 1.3.1'
pod 'DoubanObjCFileManager',     '~> 1.0.0'
pod 'YAUIKit',                   '~> 1.1.6'
pod 'SVProgressHUD',             '~> 1.0'
pod 'SDWebImage',                '3.5.2'
pod 'FXBlurView',                '~> 1.6.1'
pod 'SORelativeDateTransformer', '~> 1.1.10'
pod 'PSTCollectionView',         '~> 1.2.0'
pod 'DOUSNSSharing',             '~> 2.3.6'
pod 'DOURegisterKit',            '~> 1.2.1'
pod 'ActionSheetPicker',         '~> 0.0.2'
pod 'Weibo',                     '~> 2.4.2'
pod 'UIImage+BlurredFrame'
pod 'JSQSystemSoundPlayer'
pod 'MQTTKit', :git => 'https://github.com/jmesnil/MQTTKit.git', :commit => '5ee5cf3819'

Error

ArgumentError - invalid byte sequence in US-ASCII
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:106:in `fnmatch'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:106:in `block (3 levels) in relative_glob'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:105:in `each'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:105:in `any?'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:105:in `block (2 levels) in relative_glob'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:104:in `select'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:104:in `block in relative_glob'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:97:in `map'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:97:in `relative_glob'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/path_list.rb:70:in `glob'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/sandbox/file_accessor.rb:154:in `readme'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer/pod_source_installer.rb:280:in `map'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer/pod_source_installer.rb:280:in `used_files'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer/pod_source_installer.rb:255:in `clean_paths'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer/pod_source_installer.rb:157:in `clean_installation'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer/pod_source_installer.rb:82:in `clean!'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:287:in `block in clean_pod_sources'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:286:in `each'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:286:in `clean_pod_sources'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:109:in `block in download_dependencies'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/user_interface.rb:52:in `section'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:105:in `download_dependencies'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/installer.rb:90:in `install!'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/command/project.rb:40:in `run_install_with_update'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/command/project.rb:70:in `run'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/claide-0.6.1/lib/claide/command.rb:281:in `run'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/lib/cocoapods/command.rb:48:in `run'
/usr/local/Cellar/ruby/1.9.3-p374/lib/ruby/gems/1.9.1/gems/cocoapods-0.33.1/bin/pod:33:in `<top (required)>'
/usr/local/Cellar/ruby/1.9.3-p374/bin/pod:23:in `load'
/usr/local/Cellar/ruby/1.9.3-p374/bin/pod:23:in `<main>'

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.

Search for existing github issues similar to yours:
https://github.com/CocoaPods/CocoaPods/search?q=invalid+byte+sequence+in+US-ASCII&type=Issues

If none exists, create a ticket, with the template displayed above, on:
https://github.com/CocoaPods/CocoaPods/issues/new

Don't forget to anonymize any private data!

@jollychang

open #2385

@segiddins segiddins locked and limited conversation to collaborators Aug 14, 2014
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.