pod search --full chokes on cocos2d.podspec:14 #657

Closed
cricketgeek opened this Issue Nov 20, 2012 · 1 comment

Comments

Projects
None yet
2 participants

→ pod search --full BRNetworking

      ――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

Report

  • What did you do? I have a private SPECS in unison with the default SPECS repo. attempted to do a pod search --full BRNetworking and got the exception below. BRNetworking is in my private SPEC repo but doesn't seem like it has anything to do with the exception
  • What did you expect to happen?
    see the description text from my pod spec
  • What happened instead?
    ruby exception below

Stack

   CocoaPods : 0.15.2
        Ruby : ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.2.0]
    RubyGems : 1.8.24
        Host : Mac OS X 10.8.2 (12C60)
       Xcode : 4.5.2 (4G2008a)
Ruby lib dir : /Users/mark.jones/.rvm/rubies/ruby-1.9.3-p327/lib
Repositories : BR_SPECS - https://github.com/cricketgeek/Specs.git @ e0b30098081140439ac32bc67435fea05129eda2
               master - https://github.com/CocoaPods/Specs.git @ 35794927abdd5255ab6703a550e993c994e56998

Podfile

          platform :ios, '5.1'

xcodeproj 'SuperCPTest1.xcodeproj'

pod 'BRNetworking'

Error

undefined method `glob' for Rake:Module
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:343:in `add_matching'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:214:in `resolve_add'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:204:in `block in resolve'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:204:in `each'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:204:in `resolve'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:174:in `to_a'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/rake-0.9.3/lib/rake/file_list.rb:180:in `to_ary'
/Users/mark.jones/.cocoapods/master/cocos2d/2.0.0/cocos2d.podspec:14:in `block in _eval_podspec'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/specification.rb:59:in `initialize'
/Users/mark.jones/.cocoapods/master/cocos2d/2.0.0/cocos2d.podspec:1:in `new'
/Users/mark.jones/.cocoapods/master/cocos2d/2.0.0/cocos2d.podspec:1:in `_eval_podspec'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/specification.rb:11:in `eval'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/specification.rb:11:in `_eval_podspec'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/specification.rb:27:in `from_file'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:71:in `specification'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/specification/set.rb:94:in `specification'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:104:in `block in search_by_name'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:102:in `map'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:102:in `search_by_name'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:172:in `block in search_by_name'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:172:in `each'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:172:in `search_by_name'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/source.rb:220:in `search_by_name'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/command/search.rb:29:in `run'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/lib/cocoapods/command.rb:75:in `run'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.15.2/bin/pod:16:in `<top (required)>'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/bin/pod:19:in `load'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/bin/pod:19:in `<main>'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/bin/ruby_noexec_wrapper:14:in `eval'
/Users/mark.jones/.rvm/gems/ruby-1.9.3-p327/bin/ruby_noexec_wrapper:14:in `<main>'
Owner

fabiopelosin commented Nov 20, 2012

This issue should be already fixed in the rc. [sudo] gem install cocoapods --pre. Btw, the last rc didn't receive any issue so should be the soon to be released 0.16.

jzapater pushed a commit to jzapater/CocoaPods that referenced this issue Sep 17, 2013

Merge pull request #657 from kreeger/upstream
Adding new version of SKInnerShadowLayer spec.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment