Skip to content

Crash on pod install #668

Closed
thiagoperes opened this Issue Nov 30, 2012 · 3 comments

3 participants

@thiagoperes

Report

  • What did you do?

cloned repo, pod update then pod install

  • What did you expect to happen?

pods to be installed and workspace created

  • What happened instead?

crashed

Stack

   CocoaPods : 0.16.0
        Ruby : ruby 1.9.3p327 (2012-11-10 revision 37606) [x86_64-darwin12.2.1]
    RubyGems : 1.8.24
        Host : Mac OS X 10.8.2 (12C2034)
       Xcode : 4.5.2 (4G2008a)
Ruby lib dir : /Users/thiagoperes/.rvm/rubies/ruby-1.9.3-p327/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ fdb34bfcd4b71a978a77b93061c410c1f17a7008

Podfile

          platform :ios, '5.0'
pod 'SSKeychain'
pod 'AQGridView'
pod 'ASIHTTPRequest'
pod 'iCarousel'
pod 'MWPhotoBrowser'
pod 'PrettyKit'
pod 'SVProgressHUD'
pod 'HPGrowingTextView'

Error

No such file or directory - /Users/thiagoperes/trabalho/projetosxcode/BoaDiversao/Pods/iCarousel/LICENCE.md
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/local_pod.rb:349:in `read'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/local_pod.rb:349:in `license_text'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:37:in `hash_for_pod'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:29:in `block in licenses'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:28:in `each'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:28:in `licenses'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:18:in `plist'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements/plist.rb:11:in `save_as'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements.rb:16:in `block in save_as'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements.rb:15:in `each'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/generator/acknowledgements.rb:15:in `save_as'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:168:in `block in generate_target_support_files'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:164:in `each'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:164:in `generate_target_support_files'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:122:in `block (2 levels) in install!'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/user_interface.rb:77:in `message'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:121:in `block in install!'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/user_interface.rb:37:in `section'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/installer.rb:112:in `install!'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/command/install.rb:46:in `run_install_with_update'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/command/install.rb:51:in `run'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/lib/cocoapods/command.rb:75:in `run'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/gems/cocoapods-0.16.0/bin/pod:16:in `<top (required)>'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/bin/pod:19:in `load'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/bin/pod:19:in `<main>'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/bin/ruby_noexec_wrapper:14:in `eval'
/Users/thiagoperes/.rvm/gems/ruby-1.9.3-p327/bin/ruby_noexec_wrapper:14:in `<main>'
@fabiopelosin
CocoaPods member

This is usually caused by a faulty podspec that specifies a license file that does not exists. iCarousel should be updated to remove the LICENCE.md file form the license hash.

@xslim
xslim commented Dec 4, 2012

cocoapods should not crash. We need to add something like rescue

@fabiopelosin
CocoaPods member

This should be fixed in 0.17

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.