Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Subclasses #import <Pods/Pods.h> in version 0.16.0 #692

Closed
rvenable opened this Issue Dec 14, 2012 · 9 comments

Comments

Projects
None yet
6 participants

I'm not sure its a cocoapods error, but it seemed to appear in all of my projects after updating to cocoapods 0.16.0:

Anytime I make a new subclass of a class in the Pods project, Xcode doesn't #import the correct header file, and instead it #imports <Pods/Pods.h>.

I'm guessing it is a side effect of some project configuration that cocoapods is doing differently now, but it is a nuisance having to correct the #import statements each time.

Owner

alloy commented Dec 14, 2012

Can you look into what settings we might change in order to get Xcode to do the right thing?

This is happening for me as well. I'm also using version 0.16.0. I'm relatively new to Xcode so I doubt I can offer any assistance unless given steps to take.

I'm having the same issue.

Same here! I am having the same issue.

holysin commented Jan 10, 2013

Yeah, I got the same problem

I stopped importing Pods/Pods.h and instead imported the file as is. Now its working! Let me know if it helps or if you need any help.

Owner

alloy commented Jan 10, 2013

I think this started happening after a recent Xcode update, it would be great if anyone can investigate if that's true, what the root cause is, and what we can do about it.

rvenable commented Feb 5, 2013

This appears to be fixed in Cocoapods 0.16.2. I reproduced the bug in a project, then ran pod update using 0.16.2 and the bug was no longer reproducible. I am also on Xcode 4.6.

@rvenable rvenable closed this Feb 5, 2013

Owner

alloy commented Feb 5, 2013

Cool thanks, it might have been this fix then: CocoaPods/Xcodeproj#48 / #747.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment