NoMethodError - undefined method `index' for nil:NilClass /usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/generator/documentation.rb:30:in `already_installed?' #906

Closed
KieranLafferty opened this Issue Mar 26, 2013 · 0 comments

Comments

Projects
None yet
1 participant

Report

  • What did you do?
    Pod install after updating to latest RC
  • What did you expect to happen?
  • What happened instead?

Stack

   CocoaPods : 0.17.0.rc7
        Ruby : ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.0]
    RubyGems : 1.8.24
        Host : Mac OS X 10.8.3 (12D78)
       Xcode : 4.6.1 (4H512)
Ruby lib dir : /usr/local/rvm/rubies/ruby-1.9.3-p194/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ e96637bdcb9eedcc31804b4daeb6c9d86cf51144

Podfile

platform :ios, '5.0' 
# Or platform :osx, '10.7'
pod 'OnTab', :git=>'https://github.com/bmalek/OnTab_Apps_iOS_API.git' (private repo) 
pod 'DCRoundSwitch', '~> 0.0.1'
pod 'REFormattedNumberField', '~> 1.0.1'
pod 'JASidePanels', '~> 1.3.0'

Error

NoMethodError - undefined method `index' for nil:NilClass
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/generator/documentation.rb:30:in `already_installed?'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer/pod_source_installer.rb:129:in `generate_docs'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer/pod_source_installer.rb:77:in `install!'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:249:in `install_source_of_pod'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:219:in `block (2 levels) in install_pod_sources'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/user_interface.rb:73:in `titled_section'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:218:in `block in install_pod_sources'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:216:in `each'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:216:in `install_pod_sources'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:101:in `block in download_dependencies'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/user_interface.rb:52:in `section'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:99:in `download_dependencies'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/installer.rb:85:in `install!'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/command/project.rb:40:in `run_install_with_update'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/command/project.rb:70:in `run'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/claide-0.2.0/lib/claide.rb:535:in `run'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/lib/cocoapods/command.rb:36:in `run'
/usr/local/rvm/gems/ruby-1.9.3-p194/gems/cocoapods-0.17.0.rc7/bin/pod:16:in `<top (required)>'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `load'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/pod:19:in `<main>'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
/usr/local/rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

alloy closed this in 827cf40 Mar 28, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment