"pod search" abnormal working #917

Closed
sseen opened this Issue Mar 30, 2013 · 2 comments

Comments

Projects
None yet
2 participants

sseen commented Mar 30, 2013

$:pod search JSONKit
[ARCHelper (2.1)] The use of post_install by overriding the method is deprecated.
[ARCMacro (1.1)] The use of post_install by overriding the method is deprecated.
[BeamMusicPlayerViewController (0.1.0)] preferred_dependency has been renamed to default_subspec.
[BrynKit (1.2.1)] preferred_dependency has been renamed to default_subspec.
[CocoaLibSpotify (2.4.2)] The use of post_install by overriding the method is deprecated.
[CoconutKit (2.0.2)] The use of pre_install by overriding the method is deprecated.
[CoconutKit (2.0.2)] The use of post_install by overriding the method is deprecated.
Skipping Colours because the podspec contains errors.
[DTCoreText (1.3.2)] The use of post_install by overriding the method is deprecated.
[Ejecta (1.2)] preferred_dependency has been renamed to default_subspec.
[expat (2.1)] The use of pre_install by overriding the method is deprecated.
[freexl (1.0.0d)] The use of pre_install by overriding the method is deprecated.
[geos (3.3.7)] The use of pre_install by overriding the method is deprecated.
[GHSidebarNav (1.0.0)] The use of post_install by overriding the method is deprecated.
[GrannySmith (1.0.1)] The use of post_install by overriding the method is deprecated.
[HockeySDK (3.0.0)] The use of post_install by overriding the method is deprecated.
[iOS-FakeWeb (0.1.0)] preferred_dependency has been renamed to default_subspec.
[iPhoneMK (1.2.1)] preferred_dependency has been renamed to default_subspec.
[jsoncpp (0.6.2.rc2)] The use of pre_install by overriding the method is deprecated.
[LevelDB-ObjC (0.0.1)] The use of pre_install by overriding the method is deprecated.
[LibComponentLogging-Core (1.3.1)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-Crashlytics (1.0.0)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-LogFile (1.2.1)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-NSLog (1.0.4)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-NSLogger (1.0.4)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-pods (0.0.1)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-qlog (1.1.1)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-SystemLog (1.2.1)] The use of post_install by overriding the method is deprecated.
[LibComponentLogging-UserDefaults (1.0.3)] The use of post_install by overriding the method is deprecated.
[libetpan (0.0.1)] The use of pre_install by overriding the method is deprecated.
[LibYAML (0.1.4)] The use of pre_install by overriding the method is deprecated.
[MapBox (1.0.2)] The use of post_install by overriding the method is deprecated.
[MKStoreKit (4.99)] The use of post_install by overriding the method is deprecated.
[OLImageView (1.1.0)] preferred_dependency has been renamed to default_subspec.
[proj4 (4.8.0)] The use of pre_install by overriding the method is deprecated.
[QuickDialog (0.7)] The use of post_install by overriding the method is deprecated.
[ReactiveCocoa (1.4.0)] The use of pre_install by overriding the method is deprecated.
[RestKit (0.20.0)] preferred_dependency has been renamed to default_subspec.
[Sealant (1.0)] preferred_dependency has been renamed to default_subspec.
[SinglySDK (1.2.3)] The use of pre_install by overriding the method is deprecated.
[SSToolkit (1.0.3)] The use of post_install by overriding the method is deprecated.
[Three20 (1.0.11)] preferred_dependency has been renamed to default_subspec.
[TouchDB (1.0)] The use of post_install by overriding the method is deprecated.
[unoffical-twitter-sdk (0.0.1)] The use of post_install by overriding the method is deprecated.
[WhirlyGlobe (2.0)] preferred_dependency has been renamed to default_subspec.
[WorkflowSchema (0.5.0)] preferred_dependency has been renamed to default_subspec.
[XingSDK (0.1.0)] The use of post_install by overriding the method is deprecated.
[yajl (2.0.4)] The use of pre_install by overriding the method is deprecated.

――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

Report

  • What did you do?
  • What did you expect to happen?
  • What happened instead?

Stack

   CocoaPods : 0.17.0
        Ruby : ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]
    RubyGems : 2.0.3
        Host : Mac OS X 10.8.3 (12D78)
       Xcode : 4.6 (4H127)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 4f744f7e7467a6457665a959e33115bb91a62779

Error

Errno::ENOENT - No such file or directory - /Users/******/Library/Caches/CocoaPods/search_index.yaml
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/sources_manager.rb:103:in `initialize'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/sources_manager.rb:103:in `open'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/sources_manager.rb:103:in `updated_search_index'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/sources_manager.rb:67:in `search_by_name'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/command/search.rb:34:in `run'
/Library/Ruby/Gems/1.8/gems/claide-0.2.0/lib/claide.rb:535:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/lib/cocoapods/command.rb:36:in `run'
/Library/Ruby/Gems/1.8/gems/cocoapods-0.17.0/bin/pod:16
/usr/bin/pod:19:in `load'
/usr/bin/pod:19

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

@alloy alloy closed this in d63e2ab Mar 30, 2013

Owner

alloy commented Mar 30, 2013

I’ll release this later today, for now you can workaround it by first creating the /Users/******/Library/Caches/CocoaPods directory yourself.

sseen commented Mar 30, 2013

Thank you for your help!

jzapater pushed a commit to jzapater/CocoaPods that referenced this issue Sep 17, 2013

Merge pull request #917 from gargs/master
Changes the JSONKit 1.5pre url to use https so that it isn't blocked by corporate firewalls
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment