Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Improve the lockfile version warning message #1758

Merged
merged 1 commit into from

2 participants

@wilkinsona

Correct a typo and improve the warning message that's shown when the lock file was created with a newer version of CocoaPods.

@wilkinsona wilkinsona Improve the lockfile version warning message
Correct a typo and improve the warning message that's shown when the
lock file was created with a newer version of CocoaPods.
8073d99
@orta
Owner

Agreed, thanks @wilkinsona !

@orta orta merged commit 9a369fa into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 19, 2014
  1. @wilkinsona

    Improve the lockfile version warning message

    wilkinsona authored
    Correct a typo and improve the warning message that's shown when the
    lock file was created with a newer version of CocoaPods.
This page is out of date. Refresh to see the latest.
Showing with 3 additions and 3 deletions.
  1. +3 −3 lib/cocoapods/installer.rb
View
6 lib/cocoapods/installer.rb
@@ -155,15 +155,15 @@ def generate_pods_project
# @return [void]
#
- # @note The warning about the version of the Lockfile doesn't uses the
+ # @note The warning about the version of the Lockfile doesn't use the
# `UI.warn` method because it prints the output only at the end
# of the installation. At that time CocoaPods could have crashed.
#
def analyze
if lockfile && lockfile.cocoapods_version > Version.new(VERSION)
STDERR.puts '[!] The version of CocoaPods used to generate the lockfile is '\
- 'higher that the one of the current executable. Incompatibility ' \
- 'issues might arise.'.yellow
+ 'higher than the version of the current executable. Incompatibility ' \
+ 'issues may arise.'.yellow
end
analyzer = Analyzer.new(sandbox, podfile, lockfile)
Something went wrong with that request. Please try again.