Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't specify version constraints in combination with `project_name` parameter #587

Closed
koenpunt opened this issue Sep 9, 2019 · 3 comments

Comments

@koenpunt
Copy link

commented Sep 9, 2019

I'm trying to use generate_multiple_pod_projects with incremental_installation, but it seems that when specifying a specific project name for a pod, it's not allowed to still specify a version constraint.

Contrived Podfile example;

install! 'cocoapods',
         generate_multiple_pod_projects: true,
         incremental_installation: true

target 'Example' do
  pod 'FBSDKCoreKit', '~> 5.0.0', project_name: 'FacebookSDK'
  pod 'FBSDKLoginKit', '~> 5.0.0', project_name: 'FacebookSDK'
  pod 'FBSDKShareKit', '~> 5.0.0', project_name: 'FacebookSDK'
end

Would result in:

$ pod install
[!] A dependency with an external source may not specify version requirements (FBSDKCoreKit)

Is this the intended behavior, or is this a bug?

I'm using CocoaPods v1.7.5.

@dnkoutso

This comment has been minimized.

Copy link
Contributor

commented Sep 9, 2019

Works for me:

use_frameworks!
platform :ios, '12.0'

install! 'cocoapods',
         generate_multiple_pod_projects: true,
         incremental_installation: true

target 'SampleApp' do
  pod 'FBSDKCoreKit', '~> 5.0.0', project_name: 'FacebookSDK'
  pod 'FBSDKLoginKit', '~> 5.0.0', project_name: 'FacebookSDK'
  pod 'FBSDKShareKit', '~> 5.0.0', project_name: 'FacebookSDK'
end

Screen_Shot_2019-09-09_at_11_24_56_AM

Seems like a user error. Going to preemptively close but @koenpunt I will reopen it if we identify a bug.

Can you please your full Podfile or a sample app with a minimal Podfile that demonstrates the problem? Look in your Podfile for all pod declarations of FBSDKCoreKit.

@dnkoutso dnkoutso closed this Sep 9, 2019

@koenpunt

This comment has been minimized.

Copy link
Author

commented Sep 12, 2019

Your example doesn't work with CocoaPods v1.7.5. So I'd appreciate it you reopen this issue.

@koenpunt

This comment has been minimized.

Copy link
Author

commented Sep 12, 2019

Oh my bad, generate_multiple_pod_projects is supported by 1.7.5, but project_name was only introduced in 1.8.0.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.