Skip to content
This repository

The models used within the cocoapods gem

README.md

CocoaPods Core

Build Status Coverage Status Code Climate

The CocoaPods-Core gem provides support to work with the models of CocoaPods. It is intended to be used in place of the CocoaPods when the installation of the dependencies is not needed. Therefore, it is suitable for web services.

Provides support for working with the following models:

The gem also provides support for ancillary features like Pod::Specification::Set::Presenter suitable for presetting descriptions of Pods and the Specification::Linter, which ensures the validity of podspec files.

Installation

$ [sudo] gem install cocoapods-core

The cocoapods-core gem requires either:

  • Ruby 1.8.7 (shipped with OS X 10.8).
  • Ruby 1.9.3 (recommended).

Collaborate

All CocoaPods development happens on GitHub, there is a repository for CocoaPods and one for the CocoaPods specs. Contributing patches or Pods is really easy and gratifying.

Follow @CocoaPods to get up to date information about what's going on in the CocoaPods world.

License

This gem and CocoaPods are available under the MIT license.

Something went wrong with that request. Please try again.