Permalink
Browse files

[Rakefile] compatibility for CocoaPods < 0.6.0rc1

  • Loading branch information...
fabiopelosin committed Apr 24, 2012
1 parent 3179cc4 commit 803540f94823ff6405ffba55260f12502945fb03
Showing with 4 additions and 1 deletion.
  1. +4 −1 Rakefile
View
@@ -35,10 +35,13 @@ task :lint do
specs = FileList['**/*.podspec'] if specs.empty?
failures = []
+ version = `pod --version`
+ options = version =~ /0\.[1-5]\..*/ ? '--verbose' : '--quick --only-errors'
specs.each do |spec|
begin
next if not File.exists? spec
- command = "pod spec lint '#{spec}' --quick --only-errors"
+ # Transition to 0.6
+ command = "pod spec lint '#{spec}' #{options}"
puts command
# do it this way so we can trap Interrupt, doesn't work well with Kernel::system and Rake's sh
puts `#{command}`

0 comments on commit 803540f

Please sign in to comment.