Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Three20 not compatible with CocoaPods 0.17 #1458

Closed
fabiopelosin opened this Issue · 5 comments

3 participants

@fabiopelosin

This podspec is not compatible with CocoaPods 0.17 as it has been refactored and the Pod::Specification#pattern_list. Doesn't exits anymore.

[error] The specification defined in `Three20/1.0.11/Three20.podspec` could not be loaded.

Invalid `Three20.podspec` file: undefined method `pattern_list' for Pod::Specification:Class
 #
 #  from Three20/1.0.11/Three20.podspec:7
 #  -------------------------------------------
 #    def private_header_files=(patterns)
 >      @private_header_files = Pod::Specification::pattern_list(patterns)
 #      @private_headers_set = nil
 #  -------------------------------------------
 #
  - Three20/1.0.11/Three20.podspec (unknown)

@jeanregisser @dlackty, @garthex and @jinthagerman. As you have contributed to this podspec could you chime in and help us resolve this issue?

@jeanregisser

I'll have a look later today.

@fabiopelosin

Thanks!

@jeanregisser

Should be good now!

@dlackty

Nice work @jeanregisser! :+1:

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.