Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

MKNetworkKit incompatible with ShareKit #410

Closed
braceta opened this Issue · 1 comment

2 participants

@braceta

Hi,

If you try to combine MKNetworKit 0.83 with ShareKit 2.0 the Pod project won't compile.

This is due to the #import "MKNetworkKit.h" in the Pods-prefix.pch placed by the MKNetworkKit podspec that somehow is breaking the code for ShareKit.

The Podfile to reproduce the problem.

platform :ios
pod 'MKNetworkKit',      '~> 0.83'
pod 'ShareKit/Facebook', '~> 2.0'

I believe the fix has to be done in MKNetworkKit project by importing MKNetworkKit.h in every required file instead of the Pod-prefix.pch file.

@fabiopelosin

I believe the fix has to be done in MKNetworkKit project by importing MKNetworkKit.h in every required file instead of the Pod-prefix.pch file.

Indeed, maybe you can make a pull request on MKNetworkKit. Anyway there could be an alternative in the future CocoaPods/CocoaPods#302 (but don't expect it coming soon).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.