Remove YandexMapKit 0.0.1, 1.0.1, 1.0.2, 1.0.3 #1150

Merged
merged 1 commit into from Jan 29, 2013

Conversation

Projects
None yet
3 participants

eploko commented Jan 28, 2013

We've decided to cease support for the previous version of the Yandex MapKit framework. This pull request removes the podspecs for old versions (< 1.0.4) from the repo.

Member

keith commented Jan 28, 2013

Since users could have already integrated these projects in their Podfile we don't allow removal of podspecs. Since if they tried to re-run pod install their project could break. You can continue to add new specs of higher versions and most new users will probably go the the newer ones. The only exception I can see to this is if the repo has to be deleted entirely (which I'm definitely not recommending).

@keith keith closed this Jan 28, 2013

eploko commented Jan 29, 2013

The issue here lies in the fact that the specs point to a .zip source archive which is no longer available. So the builds will fail anyway.

@keith keith reopened this Jan 29, 2013

keith added a commit that referenced this pull request Jan 29, 2013

Merge pull request #1150 from eploko/remove-no-longer-supported-yande…
…x-mapkit-versions

Remove YandexMapKit 0.0.1, 1.0.1, 1.0.2, 1.0.3

@keith keith merged commit 41f2237 into CocoaPods:master Jan 29, 2013

1 check passed

default The Travis build passed
Details
Member

keith commented Jan 29, 2013

That's unfortunate. Merged.

eploko commented Jan 30, 2013

Thanks a ton!

@eploko eploko deleted the eploko:remove-no-longer-supported-yandex-mapkit-versions branch Jan 30, 2013

Contributor

yas375 commented on a6a84a3 Jan 30, 2013

@eploko Why did you remove these specs? Other developers may depend on them.

@yas375 The .zip archive referenced in the source field of the spec is no longer available.

@yas375 There's a newer version, 1.0.4, that the developers are advised to migrate to.

Contributor

yas375 replied Jan 30, 2013

You shouldn't remove old specs. And it's a bad practice to remove previously used zip...
Please don't remove old specs in future. And please leave zip archives for outdated versions on your server as is. Some people may still use them. They might be don't have plans to update your library in theirs projects the same day with you ;)

@alloy I think that we should have a wiki page 'Why you shouldn't remove specs for outdated versions of your library' to refer to)

@yas375 I perfectly understand that and thoroughly agree, but... the .zip had been removed. Leaving the broken specs behind doesn't seem to be good either.

Contributor

yas375 replied Jan 30, 2013

@eploko in this case yes) Hope that Yandex's employees will do the things better next time and willn't remove zip archives which are referenced from pod specs ;)

Member

keith replied Jan 30, 2013

@yas375 as you can see in our discussion I voiced these issues, but since the source files are no longer available we really had no choice.

Contributor

yas375 replied Jan 30, 2013

@keithbsmiley thanks for pointing me.

keith added a commit that referenced this pull request Jan 29, 2014

Merge pull request #1150 from eploko/remove-no-longer-supported-yande…
…x-mapkit-versions

Remove YandexMapKit 0.0.1, 1.0.1, 1.0.2, 1.0.3
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment