Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

OHHTTPStubs need ARC enabled in order for responseWithError to work #816

Merged
merged 1 commit into from

3 participants

@ruiwen

As per the title =)

@rsobik rsobik merged commit 02b6039 into CocoaPods:master
@AliSoftware

Thanks for uploading this podspec for my library!

This issue with responseWithError: has been fixed two month ago in version 1.0.4 (see ChangeLog and issue 6 for more info)

So ARC is no longer needed since those new versions!

I just uploaded the PodSpec for the latest version OHHTTPStubs/1.1.0, feel free to update your Podfiles :)

Thanks!

@kbessiere kbessiere referenced this pull request from a commit
@fabiopelosin fabiopelosin Merge branch 'master' of github.com:CocoaPods/CocoaPods
* 'master' of github.com:CocoaPods/CocoaPods:
  Bump ActiveSupport dependency to *not* be 3.2.6, which has an inflector bug. Fixes #816.
6dc02bd
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 1 deletion.
  1. +2 −1  OHHTTPStubs/1.0.1/OHHTTPStubs.podspec
View
3  OHHTTPStubs/1.0.1/OHHTTPStubs.podspec
@@ -7,4 +7,5 @@ Pod::Spec.new do |s|
s.authors = {'Olivier Halligon' => 'olivier.halligon+ae@gmail.com'}
s.source = { :git => 'https://github.com/AliSoftware/OHHTTPStubs.git', :tag => '1.0.1' }
s.source_files = 'OHHTTPStubs'
-end
+ s.requires_arc = true
+end
Something went wrong with that request. Please try again.