Add support for universal-darwin10.0 via st.h check. #25

Merged
merged 1 commit into from Aug 22, 2012

Projects

None yet

3 participants

@phillbaker

As mentioned and demo'ed in a couple of reports, this is an issue installing cocoapods on older systems (CocoaPods/CocoaPods#257). The fallback to HAVE_ST_H is from the postgres ruby driver, the syck gem also has a similar check. There does seem to be some division over #include <st.h> and #include "st.h", I went for the latter to prefer the ruby-specific version of the header.

@travisbot

This pull request passes (merged 430b22f into e5e7bdf).

@alloy
Member
alloy commented Aug 22, 2012

Awesome, thanks a lot! I’ll release this immediately.

@alloy alloy merged commit 55535ce into CocoaPods:master Aug 22, 2012

1 check passed

Details default The Travis build passed
@alloy alloy added a commit that referenced this pull request Aug 22, 2012
@alloy alloy Awesome, #25 does indeed fix build on Travis. f972f1e
@alloy
Member
alloy commented Aug 22, 2012

Released: http://rubygems.org/gems/xcodeproj/versions/0.3.2. Thanks!

Let me know if you wish push access to this repo and the CocoaPods repo.

@phillbaker

Awesome, thanks.

Sure, push would be great.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment