Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Server automation framework and application

This branch is 15094 commits behind puppetlabs:master

Fix #3167 Duplicate constant warnings in dpkg.rb

There's a limitation in Ruby 1.8.x that makes constants behave
differently than developers seem to expect:
Constants defined inside a do/end block do not get inserted into the
namespace of 'self', they instead go into the toplevel (Object)
namespace.
These providers exhibit bugs since they use constants with the same
name in the same namespace.
Other providers and other dynamically generated classes using constants
without an explicit namespace should be considered to have a code smell.

Signed-off-by: Jesse Wolfe <jes5199@gmail.com>
latest commit c6f02f2ee0
@jes5199 jes5199 authored

README.rst

Puppet

Puppet, an automated administrative engine for your Linux and Unix systems, performs administrative tasks (such as adding users, installing packages, and updating server configurations) based on a centralized specification.

Documentation (and detailed install instructions) can be found online at the Puppet Wiki.

Installation

Generally, you need the following things installed:

  • Ruby >= 1.8.1 (earlier releases might work but probably not)

  • The Ruby OpenSSL library. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -ropenssl -e "puts :yep"'. If that errors out, you're missing the library.

    If your distribution doesn't come with the necessary library (e.g., on Debian and Ubuntu you need to install libopenssl-ruby), then you'll probably have to compile Ruby yourself, since it's part of the standard library and not available separately. You could probably just compile and install that one library, though.

  • The Ruby XMLRPC client and server libraries. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -rxmlrpc/client -e "puts :yep"'. If that errors out, you're missing the library.

  • Facter => 1.1.1 You can get this from your package management system or the Facter site

Something went wrong with that request. Please try again.